PAT 1083 List Grades python解法

1083 List Grades (25 分)
Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:
Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE

解题思路:此题虽然给了3个值(name,ID,grade),但有用的只有grade,所以可以把前两个值合并成一个值,这就很自然想到了利用字典这个数据结构。将name+ID作为键,grade作为值存储起来,然后对字典作循环,先删除掉不在范围之内的数据,再将剩下的数据按照值逆序输出即可,注意当字典为空时输出NONE。

n = int(input())
student_list = {}
for i in range(n):
    name,ID,grade= map(str,input().split())
    key = name+' '+ID
    student_list[key] = int(grade)
minn, maxn = map(int,input().split())

delete = []
for key,value in student_list.items():
    if value < minn or value > maxn:
        delete.append(key)
for k in delete:
    del student_list[k]
    
if len(student_list):
    for k in sorted(student_list, key=student_list.__getitem__, reverse=True):
        print(k)
else:
    print('NONE')

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)