HDU1093

A+B for Input-Output Practice (V)

java

  • Problem Description
    Your task is to calculate the sum of some integers.

  • Input
    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

  • Output
    For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

  • Sample Input
    2
    4 1 2 3 4
    5 1 2 3 4 5

  • Sample Output
    10
    15

import java.util.Scanner;
public class Main{
	public static void main(String[] args){
		Scanner input = new Scanner(System.in);
		int x = input.nextInt();    //输入接下来的数据组数
		for(int i = 1; i <= x; i++){
			int y = input.nextInt();    //输入一组中有多少个数
			int []a = new int[100];    //定义数组储存一组数据中的y个数
			int sum = 0;
			for(int j = 0;j<y;j++){
				a[j] = input.nextInt();    //将输入的y个数放到数组中
				sum += a[j];    //对y个数求和
			}
			System.out.println(sum);    //打印结果
		}
	}
}

你可能感兴趣的:(HDU1093)