【python】PAT甲级1004 Counting Leaves (30/30分)

  1. 题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node(ID非叶节点编号,两位数), K is the number of its children, followed by a sequence of two-digit ID’s of its children. (ID子借点的编号,依旧是两位数)For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.(N为0时情况)
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root.(树的每一层上的叶节点数量) The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

  1. 代码
tree=dict() #用字典储存树的信息
n,m=map(int,input().split())
for i in range(m):
    inp=list(input().split())
    ID=inp[0]
    k=inp[1]
    inp=inp[2:]
    tree[ID]=inp

now=["01"]
#逐层遍历
out=''
while 1:
    count=0
    level=[]
    for i in now:
        if tree.get(i):
            level=level+tree.get(i)
        else:
            count+=1
    
    now=level
    out=out+str(count)+" "
    #该层无节点时终止
    if level==[]:
        break
#输出格式,末尾不能有空格
print(out[:-1])

你可能感兴趣的:(PAT)