【python】PAT1009 Product of Polynomials (25/25分)

  1. 题目

This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯ Output Specification:

For each test case you should output the product(积) of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

  1. 代码
A=list(map(float,input().split()))
An=int(A.pop(0))

B=list(map(float,input().split()))
Bn=int(B.pop(0))

outlist=dict()
for i in range(An):
    for j in range(Bn):
        xx=outlist.get(A[2*i]+B[2*j],0)+A[2*i+1]*B[2*j+1]
        if xx!=0:
            outlist[A[2*i]+B[2*j]]=xx
        else:
            outlist.pop(A[2*i]+B[2*j])

outlist=sorted(outlist.items(),key=lambda x: -x[0])
out=str(len(outlist))
for i in outlist:
    out+=" %d %.1f"%(i[0],i[1])#%.1f 自动四舍五入
print(out)

你可能感兴趣的:(PAT)