Setup TAHI environment for IPv6 test

1. Find a PC with 2 Ethernet cards

2. Install FreeBSD 7.3 on this PC, and set network connecting to internet.
3. After Installed,run cmd:

1. ntpdate clock.stdtime.gov.tw 2. portsnap fetch extract 3. cd /usr/ports/lang/p5-Expect 4. make install 5. cd /usr/ports/security/p5-Digest-MD5 6. make install 7. cd /usr/ports/textproc/p5-YAML 8. make install 9. cd /usr/ports/lang/p5-Expect 10. make install 11. cd /usr/ports/security/p5-Digest-MD5 12. make install 13. cd /usr/ports/textproc/p5-YAML 14. make install

4.Copy packages of IPv6 Test Tools v6eval-3.3.1.tar.gz v6eval-remotes-3.0 and self_test_5-0-0.tgz.tar to FreeBSD. 
5.Install tahi package 
 Commands:
  1. tar zxvf v6eval-3.3.1.tar.gz
  2. cd v6eval-3.3.1
  3. make
  4. make install
  5. tar zxvf self_test_5-0-0.tgz.tar
  6. tar -zxvf v6eval-remotes-3.0.tar.gz
  7. cd v6eval-remotes-3.0
  8. make
  9. make install
  10. touch /var/log/aculog
  11. chown uucp:dialer /var/log/aculog
  12. chmod 660 /var/log/aculog 
  13. cu -l /dev/cuad0 -s 115200
  14. use "~." to exit RS232C 

6. set environment for IPv6 Test tools

  • Set FreeBSD Network for IPv6 Test tools
    • modify /etc/rc.conf
      • ipv6_enable=“NO”
      • ifconfig_rl0=“up” ,(rl0 is interface name of FreeBSD PC, this name maybe different on different PC)
      • ifocnifg_rl1=“up” ,(rl1 is interface name of FreeBSD PC, this name maybe different on different PC)
  • Set Config for IPv6 Test Tools
    • Create nut.def and tn.def in /usr/local/v6eval/etc
      • Copy nut.def.sample to nut.def in /usr/local/v6eval/etc
      • Copy tn.def.sample to tn.def in /usr/local/v6eval/etc
      • Modify tn.def
        • Modify the name : Link0 = rl0 and Link1 = rl1
        • Modify the macid: mac of Link0 = macid of rl0, mac of Link1 = macid of rl1,
      • Modify nut.def
        • Modify “type” to be router
        • Remove # before Link1 to enable Link1

7.set dut

  • Clear all settings
  • set macid:00:E0:4C:81:86:82
  • set pvc0=0/33
  • create static IP Address base on pv0
    • External IP Address = 192.168.11.11
    • Default Gateway = 192.168.11.1
    • MAC Address = 00:E0:4C:81:86:90

8.Start test:

  • Switch to Selftest folder(the folder of self_test_5-0-0)
  • execute “make clean”
  • execute “make ipv6ready_p1_router” or “make ipv6ready_p2_router”

你可能感兴趣的:(linux,kernel)