Nearest Common Ancestors

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
Nearest Common Ancestors_第1张图片

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5
Sample Output
4
3

import java.io.BufferedInputStream;
import java.util.Arrays;
import java.util.Scanner;

public class Main{ 
	/*  [8.10~8.16]倍增 LCA RMQ
	 * */
	static final int N=(int)1e4+5;
	static final int INF=(int)1e6;
	static int []fa;
	static int n;
	static boolean []vis;
	
	public static void main(String[] args) {
		init();
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int t=sc.nextInt();
		while(t-->0) {
			n=sc.nextInt();
			//初始化
			for(int i=0;i<=n;i++) {
				vis[i]=false;
				fa[i]=i;
			}
			int a,b;
			//存边信息
			for(int i=1;i<n;i++) {
				a=sc.nextInt();b=sc.nextInt();
				fa[b]=a;
			}
			//要查询的信息
			int x=sc.nextInt(),y=sc.nextInt();
			//解决
			vis[x]=true;
			x=fa[x];
			while(x!=fa[x]) {
				vis[x]=true;
				x=fa[x];
			}
			while(y!=fa[y]) {
				if(vis[y]) break;
				y=fa[y];
			}
			System.out.println(y);
		}
	}
	static void init() {
		fa=new int [N];
		vis=new boolean [N];
	}
}

你可能感兴趣的:(LCA)