Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
矩阵快速幂入门,照着给的公式用一下就行
本题让没接触矩阵运算的我对矩阵乘法,单位矩阵有了一些认识
AC代码
#include"iostream"
#include"string.h"
#include"algorithm"
using namespace std;
typedef long long ll;
struct MUL{
ll mul[10][10];
}start;
MUL ksm(MUL x,MUL y){
MUL z;
memset(z.mul,0,sizeof(z.mul));
for(int i=1;i<=2;i++){
for(int j=1;j<=2;j++){
for(int k=1;k<=2;k++){
z.mul[i][j] += x.mul[i][k] * y.mul[k][j]%10000;//取后4位
z.mul[i][j] %= 10000;
}
}
}
return z;
}
ll jzksm(MUL x,ll n){
MUL res;
memset(res.mul,0,sizeof(res.mul));
for(int i=1;i<=2;i++){//单位矩阵对角线赋值1,其余全为0,单位矩阵相当于数值中的1
res.mul[i][i]=1;
}
while(n){//快速幂,不知道的小伙伴请百度一下
if(n&1){
res=ksm(x,res);
}
x=ksm(x,x);
n>>=1;
}
return res.mul[1][2]%10000;
}
int main()
{
ll w;
while(cin>>w){
if(w==-1){
break;
}
start.mul[1][1]=start.mul[1][2]=start.mul[2][1]=1;
start.mul[2][2]=0;
cout<