算法训练 最长字符串

  求出5个字符串中最长的字符串。每个字符串长度在100以内,且全为小写字母。
样例输入
one two three four five
样例输出
three


#include "stdio.h"
#include "string.h"
int main()
{
    char arr[5][101];
    int i,max ;
    int n[5];
    for(i=0;i<5;i++)
    {
        scanf("%s",arr[i]);
        n[i]=strlen(arr[i]);
    }
    max=0 ;
    for(i=1;i<5;i++)
    {
        if(n[max]




你可能感兴趣的:(算法训练 最长字符串)