HDU5973 Game of Taking Stones (大数博弈)

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 458    Accepted Submission(s): 175


Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
 

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
 

Sample Input
 
   
2 1 8 4 4 7
 

Sample Output
 
   
0 1 0
 

Source
2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)


思路:一个大数博弈,除去大数外算是威佐夫博弈的模板题目,利用java用BigDecimal类来保证高精度,用二分法来求解sqrt(5),先说下关于二分法求解开根号的思想,先把给定的数均分,然后相乘判断与要开方的数的关系,若前者大于后者,则左移,否则右移。


import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin = new Scanner(System.in);
		BigDecimal two,three,five,a,b;
		two = BigDecimal.valueOf(2);
		three = BigDecimal.valueOf(3);
		five = BigDecimal.valueOf(5);
		//二分法求sqrt(5)
		BigDecimal l = two, r = three;
		for(int i = 0; i < 500; i ++){
			BigDecimal mid = l.add(r).divide(two);
			if(mid.multiply(mid).compareTo(five) < 0)
				l = mid; //右移
			else
				r = mid; //左移
		}
		BigDecimal gold = l.add(BigDecimal.ONE).divide(two);//威佐夫博弈黄金分割率
		while(cin.hasNext()){
			a = cin.nextBigDecimal();
			b = cin.nextBigDecimal();
			if(a.compareTo(b) < 0){//a>b
				BigDecimal temp = a;
				a = b;
				b = temp;
			}
			BigDecimal temp = a.subtract(b);
			temp = temp.multiply(gold);
			temp = temp.setScale(0, BigDecimal.ROUND_FLOOR);//向下取整
			if(temp.compareTo(b) == 0)
				System.out.println("0");
			else
				System.out.println("1");
		}
	}

}


你可能感兴趣的:(ACM,博弈,博弈论)