Game of Taking Stones(double大数。二分求根5(精确))

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1522    Accepted Submission(s): 515


 

Problem Description

Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

 

 

Input

Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.

 

 

Output

For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

 

 

Sample Input

2 1

8 4

4 7

Sample Output

0

1

0

 

 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

 

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

威佐夫博弈裸题。

但是要二分进行找根5,精确到小数点后100位。

代码:

import java.math.BigInteger;
import java.math.BigDecimal;
import java.util.*;
 
public class lala {
	public static void main(String[] args)
	{
		Scanner scanner = new Scanner(System.in);
		BigDecimal TWO = BigDecimal.valueOf(2);
		BigDecimal FIVE = BigDecimal.valueOf(5);
		
		BigDecimal EPS = new BigDecimal("0.000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
		
		
		BigDecimal L = new BigDecimal("2.23");
		BigDecimal R = new BigDecimal("2.24");
		
		BigDecimal mid = null;
		
		while(L.subtract(R).compareTo(EPS) < 0)
		{
			mid = L.add(R).divide(TWO);
			if(mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0)
				break;
			if(mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0)
				L = mid;
			else
				R = mid;
		}
		
		BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
		//System.out.println(GOLD);
		
		while(scanner.hasNext())
		{
			BigDecimal a = scanner.nextBigDecimal();
			BigDecimal b = scanner.nextBigDecimal();
			if(a.compareTo(b) > 0) //保证a是小的
			{
				BigDecimal t = a;
				a = b;
				b = t;
			}
			BigDecimal c = b.subtract(a).multiply(GOLD);
			
			BigInteger aa = a.toBigInteger();
			BigInteger cc = c.toBigInteger();
			if(aa.equals(cc))
				System.out.println("0");
			else 
				System.out.println("1");
		}
	}
}

在循环里直接这样写也可以:

import java.math.BigInteger;
import java.math.BigDecimal;
import java.util.*;
 
public class lala {
	public static void main(String[] args)
	{
		Scanner scanner = new Scanner(System.in);
		BigDecimal TWO = BigDecimal.valueOf(2);
		BigDecimal FIVE = BigDecimal.valueOf(5);
		
		BigDecimal EPS = new BigDecimal("0.000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
		
		
		BigDecimal L = new BigDecimal("2.23");
		BigDecimal R = new BigDecimal("2.24");
		
		BigDecimal mid = null;
		
		///while(L.subtract(R).compareTo(EPS) < 0)
		while(1==1)
		{
			mid = L.add(R).divide(TWO);
			if(mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0)
				break;
			if(mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0)
				L = mid;
			else
				R = mid;
		}
		
		BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
		//System.out.println(GOLD);
		
		while(scanner.hasNext())
		{
			BigDecimal a = scanner.nextBigDecimal();
			BigDecimal b = scanner.nextBigDecimal();
			if(a.compareTo(b) > 0) //保证a是小的
			{
				BigDecimal t = a;
				a = b;
				b = t;
			}
			BigDecimal c = b.subtract(a).multiply(GOLD);
			
			BigInteger aa = a.toBigInteger();
			BigInteger cc = c.toBigInteger();
			if(aa.equals(cc))
				System.out.println("0");
			else 
				System.out.println("1");
		}
	}
}

 

你可能感兴趣的:(各类板子,二分)