仓鼠找sugar【LCA】

>Description
小仓鼠的和他的基(mei)友(zi)sugar住在地下洞穴中,每个节点的编号为1~n。地下洞穴是一个树形结构。这一天小仓鼠打算从从他的卧室(a)到餐厅(b),而他的基友同时要从他的卧室(c)到图书馆(d)。他们都会走最短路径。现在小仓鼠希望知道,有没有可能在某个地方,可以碰到他的基友?

小仓鼠那么弱,还要天天被zzq大爷虐,请你快来救救他吧!


>Input
第一行两个正整数n和q,表示这棵树节点的个数和询问的个数。
接下来n-1行,每行两个正整数u和v,表示节点u到节点v之间有一条边。
接下来q行,每行四个正整数a、b、c和d,表示节点编号,也就是一次询问,其意义如上。

>Output
对于每个询问,如果有公共点,输出大写字母“Y”;否则输出“N”。


>Sample Input
5 5
2 5
4 2
1 3
1 4
5 1 5 1
2 2 1 4
4 1 3 4
3 1 1 5
3 5 1 4

>Sample Output
Y
N
Y
Y
Y

20%的数据 n<=200,q<=200
40%的数据 n<=2000,q<=2000
70%的数据 n<=50000,q<=50000
100%的数据 n<=100000,q<=100000


>解题思路
最近公共祖先。

题目要求的是aa-bb的最短路有没有与cc-dd的最短路相交
因为这是一棵树,所以两点之间的最短路可以为这两点的lca分别到两点的距离(预处理深度)再相加,
如果两条路径相交了,那么就说明某一条路径的lca在另一条路径上(我也是看题解的),
如何判断:两端点的距离=lca到两端点的距离的和,就说明lca在这条最短路上

主要是学会求lca,我是用倍增算法看这个blog


>代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

struct ooo
{
	int to, next;
} a[200005];
int n, q, u, v, h[100005], t, dep[100005], f[100005][25], lg[100005], aa, bb, cc, dd;

void dfs (int s, int fath) //s是当前点,fath是s的父亲
{
	dep[s] = dep[fath] + 1; //深度
	f[s][0] = fath;
	for (int i = 1; i <= lg[dep[s]] - 1; i++)
	  f[s][i] = f[f[s][i - 1]][i - 1]; //转移:2^i=2^(i-1)+2^(i-1)
	                                   //f[i][j]:第i个节点往上2^j层的祖先
	
	for (int i = h[s]; i; i = a[i].next)
	  if (a[i].to != fath) //继续往下搜索儿子
	    dfs(a[i].to, s);
}

int lca (int x, int y)
{
	if (dep[x] < dep[y]) swap(x, y);
	while (dep[x] > dep[y])
	  x = f[x][lg[dep[x] - dep[y]] - 1]; //把x跳到与y同一高度
	if (x == y) return y; //如果x跳到了y,就说明y是两点的lca
	
	for (int i = lg[dep[x]] - 1; i >= 0; i--)
	  if (f[x][i] != f[y][i]) x = f[x][i], y= f[y][i]; //两点同时跳
	return f[x][0]; //最后两点都跳到lca的下一层,返回f[x][0]两点往上1层的祖先(父亲)
}

inline int dis (int x, int y)
{
	int l = lca (x, y);
	return dep[x] - dep[l] + dep[y] - dep[l];
} //可以用lca求距离

void work ()
{
	scanf ("%d%d%d%d", &aa, &bb, &cc, &dd);
	int x = lca (aa, bb), y = lca (cc, dd); //先求两个点lca
	
	if (dis (aa, bb) == dis (aa, y) + dis (bb, y) 
	  || dis (cc, dd) == dis (cc, x) + dis (dd, x)) //达到任何一个条件即可
	   putchar ('Y');
	else putchar ('N');
	putchar (10);
}

int main()
{
	scanf ("%d%d", &n, &q);
	for (int i = 1; i < n; i++)
	{
		scanf ("%d%d", &u, &v);
		a[++t].to = v; a[t].next = h[u]; h[u] = t;
		a[++t].to = u; a[t].next = h[v]; h[v] = t; //连接双向路
	}
	
	for (int i = 1; i <= n; i++)
	  lg[i] = lg[i - 1] + (1 << lg[i - 1] == i); //lg[i]是预处理log_2(i)+1
	for (int i = h[1]; i; i = a[i].next)
	  dfs (a[i].to, 1);
	  
	for (int i = 1; i <= q; i++)
	  work();
	return 0;
}

你可能感兴趣的:(LCA)