【Python练习】统计字符串中的字符个数

统计字符串中的字符个数
题目内容:
定义函数countchar()按字母表顺序统计字符串中所有出现的字母的个数(允许输入大写字符,并且计数时不区分大小写)。形如:
def countchar(string):
… …
return a list
if name == “main”:
string = input()
… …
print(countchar(string))
输入格式:
字符串

输出格式:
列表

输入样例:
Hello, World!

输出样例:
[0, 0, 0, 1, 1, 0, 0, 1, 0, 0, 0, 3, 0, 0, 2, 0, 0, 1, 0, 0, 0, 0, 1, 0, 0, 0]

def countchar(string):
     l = list('abcdefghijklmnopqrstuvwxyz')
     countList = []
     string = string.lower()
     for i in range(len(l)):
         countList.append(string.count(l[i]))
     return countList
if __name__ == "__main__":
     string = input()
     print(countchar(string))

你可能感兴趣的:(Python编程练习,python)