[C++]小数点位数与精度

http://ac.jobdu.com/problem.php?pid=1002

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
#include <iostream>

#include <iomanip>

using namespace std; 

float absolute(float a, float b)

{

    if(a > b)

    {

        return a-b;

    }

    return b-a;

}

int main(int argc, char** argv) { 

    float P,T,G1,G2,G3,GJ,score;

    while(cin>>P>>T>>G1>>G2>>G3>>GJ)

    {

        if(absolute(G1,G2)<=T)

        {

            score = (G1+G2)/2;

        }

        else 

        {

            float G13=absolute(G1,G3);

            float G23=absolute(G2,G3);

            if(G13 <= T && G23 <= T)

            {

                if(G1 > G2)

                {

                    if(G1 > G3)

                    {

                        score = G1;

                    }

                    else

                    {

                        score = G3;

                    }

                }

                else

                {

                    if(G2 > G3)

                    {

                        score = G2;

                    }

                    else

                    {

                        score = G3;

                    }

                }

            }

            else if(G13 <= T ^ G23 <= T)

            {

                if(G13 < G23)

                {

                    score = (G1+G3)/2;

                }

                else

                {

                    score = (G2+G3)/2;

                }

            } 

            else

            {

                score = GJ;

            }

        } 

        cout<<fixed<<setprecision(1)<<score<<endl; 

    }    

    return 0;

}

上述添加了fixed表示精度从小数点后面开始算起,setprecision就是精度位数。


本文基于知识共享署名-非商业性使用 3.0 许可协议进行许可。欢迎转载、演绎,但是必须保留本文的署名林羽飞扬,若需咨询,请给我发信

 

你可能感兴趣的:(C++)