日常生活中,局域网中出现一些问题,当管理员不在单位时,要其赶回单位解决不现实,那么怎样才能以最快的速度和效率解决问题呢,那就是远程登录。今天来看一个小型局域网的配置实验,其中还要涉及远程登录的配置。
拓扑图如下:
该小型局域网一共设置4个VLAN,即:
vlan10:222.17.193.1/26 255.255.255.192
vlan20:222.17.193.65/26 255.255.255.192
vlan30:222.17.199.1/28 255.255.255.240
vlan40:222.17.192.1/26 255.255.255.192
其中将主机0,主机1,主机2,主机3划分到vlan10和vlan20中;
vlan30则设置成为设备(左2层交换机 右2层交换机)的IP,最终用来配置远程登录;
DNS服务器和WEB服务器划分到vlan40中。
在3层交换机上,0/1 0/2口设置为trunk口,0/3 0/4口设置为access口。
在左侧2层交换机和右侧2层交换机的0/1口都设置为trunk口。
在3层交换机的IOS命令行中输入如下命令:
Switch>
Switch>enable
Switch#configure terminal
Switch(config)#hostname 3S
3S(config)#vlan 10 (创建VLAN10)
3S(config-vlan)#exit
3S(config)#vlan 20 (创建VLAN20)
3S(config-vlan)#exit
3S(config)#vlan 30 (创建VLAN30)
3S(config-vlan)#exit
3S(config)#vlan 40 (创建VLAN40)
3S(config-vlan)#exit
3S(config)#
3S(config)#interface vlan 10 (设置VLAN10的IP地址)
3S(config-if)#ip address 222.17.193.1 255.255.255.192
3S(config-if)#exit
3S(config)#interface vlan 20 (设置VLAN20的IP地址)
3S(config-if)#ip address 222.17.193.65 255.255.255.192
3S(config-if)#exit
3S(config)#interface vlan 30 (设置VLAN30的IP地址)
3S(config-if)#ip address 222.17.199.1 255.255.255.240
3S(config-if)#exit
3S(config)#interface vlan 40 (设置VLAN40的IP地址)
3S(config-if)#ip address 222.17.192.1 255.255.255.192
3S(config-if)#exit
3S(config)#interface fastEthernet 0/1 (将0/1设置为trunk口)
3S(config-if)#switchport mode trunk
3S(config-if)#exit
3S(config)#interface fastEthernet 0/2 (将0/2设置为trunk口)
3S(config-if)#switchport mode trunk
3S(config-if)#exit
3S(config)#interface fastEthernet 0/3 (将0/3设置为access口)
3S(config-if)#switchport access vlan 40
3S(config-if)#exit
3S(config)#interface fastEthernet 0/4 (将0/4设置为access口)
3S(config-if)#switchport access vlan 40
3S(config-if)#exit
3S(config)#ip dhcp pool vlan10 (设置VLAN10的DHCP)
3S(dhcp-config)#network 222.17.193.0 255.255.255.192
3S(dhcp-config)#default-router 222.17.193.1
3S(dhcp-config)#dns-server 222.17.192.2
3S(dhcp-config)#exit
3S(config)#ip dhcp pool vlan20 (设置VLAN20的DHCP)
3S(dhcp-config)#network 222.17.193.64 255.255.255.192
3S(dhcp-config)#default-router 222.17.193.65
3S(dhcp-config)#dns-server 222.17.192.2
3S(dhcp-config)#exit
3S(config)#
Switch>enable
Switch#configure terminal
Switch(config)#hostname 3S
3S(config)#vlan 10 (创建VLAN10)
3S(config-vlan)#exit
3S(config)#vlan 20 (创建VLAN20)
3S(config-vlan)#exit
3S(config)#vlan 30 (创建VLAN30)
3S(config-vlan)#exit
3S(config)#vlan 40 (创建VLAN40)
3S(config-vlan)#exit
3S(config)#
3S(config)#interface vlan 10 (设置VLAN10的IP地址)
3S(config-if)#ip address 222.17.193.1 255.255.255.192
3S(config-if)#exit
3S(config)#interface vlan 20 (设置VLAN20的IP地址)
3S(config-if)#ip address 222.17.193.65 255.255.255.192
3S(config-if)#exit
3S(config)#interface vlan 30 (设置VLAN30的IP地址)
3S(config-if)#ip address 222.17.199.1 255.255.255.240
3S(config-if)#exit
3S(config)#interface vlan 40 (设置VLAN40的IP地址)
3S(config-if)#ip address 222.17.192.1 255.255.255.192
3S(config-if)#exit
3S(config)#interface fastEthernet 0/1 (将0/1设置为trunk口)
3S(config-if)#switchport mode trunk
3S(config-if)#exit
3S(config)#interface fastEthernet 0/2 (将0/2设置为trunk口)
3S(config-if)#switchport mode trunk
3S(config-if)#exit
3S(config)#interface fastEthernet 0/3 (将0/3设置为access口)
3S(config-if)#switchport access vlan 40
3S(config-if)#exit
3S(config)#interface fastEthernet 0/4 (将0/4设置为access口)
3S(config-if)#switchport access vlan 40
3S(config-if)#exit
3S(config)#ip dhcp pool vlan10 (设置VLAN10的DHCP)
3S(dhcp-config)#network 222.17.193.0 255.255.255.192
3S(dhcp-config)#default-router 222.17.193.1
3S(dhcp-config)#dns-server 222.17.192.2
3S(dhcp-config)#exit
3S(config)#ip dhcp pool vlan20 (设置VLAN20的DHCP)
3S(dhcp-config)#network 222.17.193.64 255.255.255.192
3S(dhcp-config)#default-router 222.17.193.65
3S(dhcp-config)#dns-server 222.17.192.2
3S(dhcp-config)#exit
3S(config)#
在左侧的2层交换机IOS命令行输入如下命令:
Switch>
Switch>enable
Switch#configure terminal
Switch(config)#hostname 2Szuo
2Szuo(config)#interface fastEthernet 0/1 (将0/1口设置为trunk)
2Szuo(config-if)#switchport mode trunk
2Szuo(config-if)#exit
2Szuo(config)#vlan 10 (创建VLAN10)
2Szuo(config-vlan)#exit
2Szuo(config)#vlan 20 (创建VLAN20)
2Szuo(config-vlan)#exit
2Szuo(config)#interface fastEthernet 0/2 (将0/2口划入VLAN10中)
2Szuo(config-if)#switchport access vlan 10
2Szuo(config-if)#exit
2Szuo(config)#interface fastEthernet 0/3 (将0/3口划入VLAN20中)
2Szuo(config-if)#switchport access vlan 20
2Szuo(config-if)#exit
2Szuo(config)#vlan 30 (创建VLAN30)
2Szuo(config-vlan)#exit
2Szuo(config)#interface vlan 30 (设置左侧2层交换设备的IP地址)
2Szuo(config-if)#ip address 222.17.199.2 255.255.255.240
2Szuo(config-if)#exit
2Szuo(config)#ip default-gateway 222.17.199.1 (设置网关)
2Szuo(config)#line vty 0 4 (设置左侧2层交换机的远程登录密码)
2Szuo(config-line)#login
2Szuo(config-line)#password 123456 (左侧2层交换机远程登录密码)
2Szuo(config-line)#enable password 654321 (左侧2层交换机远程登录特权模式密码)
2Szuo(config)#
Switch>enable
Switch#configure terminal
Switch(config)#hostname 2Szuo
2Szuo(config)#interface fastEthernet 0/1 (将0/1口设置为trunk)
2Szuo(config-if)#switchport mode trunk
2Szuo(config-if)#exit
2Szuo(config)#vlan 10 (创建VLAN10)
2Szuo(config-vlan)#exit
2Szuo(config)#vlan 20 (创建VLAN20)
2Szuo(config-vlan)#exit
2Szuo(config)#interface fastEthernet 0/2 (将0/2口划入VLAN10中)
2Szuo(config-if)#switchport access vlan 10
2Szuo(config-if)#exit
2Szuo(config)#interface fastEthernet 0/3 (将0/3口划入VLAN20中)
2Szuo(config-if)#switchport access vlan 20
2Szuo(config-if)#exit
2Szuo(config)#vlan 30 (创建VLAN30)
2Szuo(config-vlan)#exit
2Szuo(config)#interface vlan 30 (设置左侧2层交换设备的IP地址)
2Szuo(config-if)#ip address 222.17.199.2 255.255.255.240
2Szuo(config-if)#exit
2Szuo(config)#ip default-gateway 222.17.199.1 (设置网关)
2Szuo(config)#line vty 0 4 (设置左侧2层交换机的远程登录密码)
2Szuo(config-line)#login
2Szuo(config-line)#password 123456 (左侧2层交换机远程登录密码)
2Szuo(config-line)#enable password 654321 (左侧2层交换机远程登录特权模式密码)
2Szuo(config)#
在右侧的2层交换机IOS命令行输入如下命令:
Switch>
Switch>enable
Switch#configure terminal
Switch(config)#hostname 2Syou
2Syou(config)#interface fastEthernet 0/1 ( 将0/1口设置为trunk)
2Syou(config-if)#switchport mode trunk
2Syou(config-if)#exit
2Syou(config)#vlan 10 (创建VLAN10)
2Syou(config-vlan)#exit
2Syou(config)#vlan 20 (创建VLAN20)
2Syou(config-vlan)#exit
2Syou(config)#interface fastEthernet 0/2 (将0/2口划入VLAN10中)
2Syou(config-if)#switchport access vlan 10
2Syou(config-if)#exit
2Syou(config)#interface fastEthernet 0/3 (将0/3口划入VLAN20中)
2Syou(config-if)#switchport access vlan 20
2Syou(config-if)#exit
2Syou(config)#vlan 30 (创建VLAN30)
2Syou(config-vlan)#exit
2Syou(config)#interface vlan 30 (设置右侧2层交换设备的IP地址)
2Syou(config-if)#ip address 222.17.199.3 255.255.255.240
2Syou(config-if)#exit
2Syou(config)#ip default-gateway 222.17.199.1 (设置网关)
2Syou(config)#line vty 0 4 (设置右侧2层交换机的远程登录密码)
2Syou(config-line)#login
2Syou(config-line)#password 123456 (右侧2层交换机远程登录密码)
2Syou(config-line)#enable password 654321(右侧2层交换机远程登录特权模式密码)
2Syou(config)#
Switch>enable
Switch#configure terminal
Switch(config)#hostname 2Syou
2Syou(config)#interface fastEthernet 0/1 ( 将0/1口设置为trunk)
2Syou(config-if)#switchport mode trunk
2Syou(config-if)#exit
2Syou(config)#vlan 10 (创建VLAN10)
2Syou(config-vlan)#exit
2Syou(config)#vlan 20 (创建VLAN20)
2Syou(config-vlan)#exit
2Syou(config)#interface fastEthernet 0/2 (将0/2口划入VLAN10中)
2Syou(config-if)#switchport access vlan 10
2Syou(config-if)#exit
2Syou(config)#interface fastEthernet 0/3 (将0/3口划入VLAN20中)
2Syou(config-if)#switchport access vlan 20
2Syou(config-if)#exit
2Syou(config)#vlan 30 (创建VLAN30)
2Syou(config-vlan)#exit
2Syou(config)#interface vlan 30 (设置右侧2层交换设备的IP地址)
2Syou(config-if)#ip address 222.17.199.3 255.255.255.240
2Syou(config-if)#exit
2Syou(config)#ip default-gateway 222.17.199.1 (设置网关)
2Syou(config)#line vty 0 4 (设置右侧2层交换机的远程登录密码)
2Syou(config-line)#login
2Syou(config-line)#password 123456 (右侧2层交换机远程登录密码)
2Syou(config-line)#enable password 654321(右侧2层交换机远程登录特权模式密码)
2Syou(config)#
主机通过DHCP获得的地址如下:
主机0
主机1
主机2
主机3
主机0和主机3互ping下,看下是否互通。
可以ping通,互通。
现在进行远程登录测试,看远程登录配置是否成功。
成功的远程登录右侧2层交换设备。
成功的远程登录左侧2层交换设备。
远程登录配置成功。
现在再来看DNS服务器和WEB服务器的配置。
WEB服务器:
DNS服务器:
开启WEB服务器服务:
开启DNS服务器服务:
现在在PC机上浏览下index.html,看服务器是否成功。
可以浏览。服务器成功。实验成功。
PS:从上星期4到昨天,我消沉了5天。这几天出了很多的事情,心里很难受,我的心里就是不能静下来。感觉人颓废了许多。我不会颓废下去的,无论遇到再大的事,再大的困难,我也要挺起胸膛走过去,加油,原海龙!