Max Sum 注意这题


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
    
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
    
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 
这个有点要注意的地方

#include <iostream>
using namespace std;

int get(int data[] , int &l , int &r , int dl)
{
     int max = -10000000 ;
     l = 0 ;
     r = 0 ;
     int t = 1 ;
     int mt = 0 ;
     for(int i = 0 ; i < dl ; i++)
     {
             mt = mt +data[i];
             if(mt > max)
             {
                            max =  mt;
                            l = t ; r = i+1 ;
             }
             
             if(mt < 0)
             {
                              mt = 0 ;
                              t = i+2 ;
             }
     }
     return max ;
}


int main()
{
    int num ; 
    cin >> num ;
    for(int k = 1 ; k <= num ;k++)
    {
              int lg = 0 ;
              cin >>lg ;
              int * data = new int[lg];
              for(int i =0 ;i < lg ; i++)
              {
                      cin >>data[i];
              }
              int l = 0 , r = lg-1 ;
              int max = 0 ;
              max = get(data , l , r , lg);
              cout<<"Case "<<k<<":"<<endl;
              cout<<max<<" "<<l<<" "<<r<<endl;
              
              if(k!=num)
              cout<<endl; 
              
    }
    return 0 ;
}
 

你可能感兴趣的:(算法)