PAT 1001 A+B Format python解法

题目
1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991


大概题意

  • 就是计算a+b的和,然后格式化输出(就是从最后一位往前开始算,每3位数字加一个逗号。)

解题思路

  • 提到格式化输出,直接用format函数。
  • format有一个千位分隔符的用法,正好和题意一样,就是每3位数字加一个逗号。

Code

a,b = map(int,input().split())
print('{:,}'.format(a+b))

运行结果
PAT 1001 A+B Format python解法_第1张图片

你可能感兴趣的:(PAT,python,算法)