(Python实现)PAT 1008 Elevator (20 分)

1008 Elevator (20 分)
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

解题思路:
用建立新的数组来存储数据,一开始在范围和索引问题上多少有点迷糊,错了好几次,然后去Google了一下参考了别人的范围和索引的处理,试出来了…(反正就是好菜一人)

代码:

elevator = list(map(int, input().split()))
result = elevator[0] * 5 + elevator[1] * 6
for i in range(2, len(elevator)):
    if elevator[i] - elevator[i-1] >= 0:
        result += 6 * (elevator[i] - elevator[i-1])
    else:
        result += 4 * (elevator[i-1] - elevator[i])
print(result)

提交记录:
(Python实现)PAT 1008 Elevator (20 分)_第1张图片

你可能感兴趣的:(每日一题,python)