PAT 1008 Elevator (20 分)————Python

1008 Elevator (20 分)
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.


Output Specification:
For each test case, print the total time on a single line.


Sample Input:

3 2 3 1

Sample Output:

41

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB


注意

  • 这道题刚开始读了半天感觉每咋弄懂,后来发现,它给的数字中,第一个数是需要停靠的次数,后面的才是想要电梯上的层数。

解题思路

  • 新建一个数组存储数字,遍历数组,判断上楼梯还是下楼梯,然后计算秒数。

Code

ls = list(map(int,input().split()))
res = ls[0]*5 + ls[1]*6
for i in range(2,len(ls)):
    if ls[i] > ls[i-1]:
        res += (ls[i] - ls[i-1]) * 6
    else:
        res += (ls[i-1] - ls[i]) * 4
print(res)


运行结果
PAT 1008 Elevator (20 分)————Python_第1张图片

你可能感兴趣的:(PAT,python,算法)