PAT 甲级 1019 General Palindromic Number(20 分)

1019 General Palindromic Number(20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB


# include 
# include ;
using namespace std;

int main(){
//	freopen("C:\\1.txt", "r", stdin);
	int n, num, flag = 0;
	vector v;
	scanf("%d %d", &n, &num);
	int i = 0;
	while(n != 0){
		v.push_back(n % num);
		n /= num;
	}
	for(int j = 0, size = v.size(); j < size / 2; j++){
		if(v[j] != v[size - 1 - j]){
			flag = 1;
			break;
		}
	}
	if(!flag) printf("Yes\n");
	else printf("No\n");
	for(i = v.size() - 1; i >= 0; i--){
		printf("%d", v[i]);
		if(i != 0) printf(" ");
	}
	if(v.size()== 0) printf("0");  // 一定要有!!!!!! 
	return 0;
} 

 

你可能感兴趣的:(PAT,甲级)