poj1088 滑雪 解题报告

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 77423   Accepted: 28779

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5


16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

Sample Output

25
记忆化搜索

#include <cstdio>

#include <cstring>

#include <algorithm>

using namespace std;

const int maxn=101;

int down[maxn][maxn];

int n,m;

int maz[maxn][maxn];

const int dx[4]={0,0,-1,1};

const int dy[4]={1,-1,0,0};



int dfs(int sx,int sy){

    if(down[sx][sy]!=-1)return down[sx][sy];

    int tmp=1;

    for(int i=0;i<4;i++){

        int tx=sx+dx[i],ty=sy+dy[i];

        if(tx>=0&&tx<n&&ty>=0&&ty<m&&maz[tx][ty]<maz[sx][sy]){

            int t=dfs(tx,ty);

            tmp=max(t+1,tmp);

        }

    }

    return down[sx][sy]=tmp;

}

int main(){

    while(scanf("%d%d",&n,&m)==2){

        for(int i=0;i<n;i++){

            for(int j=0;j<m;j++){

                scanf("%d",maz[i]+j);

            }

        }

        memset(down,-1,sizeof(down));

        int ans=0;

        for(int i=0;i<n;i++){

            for(int j=0;j<m;j++){

                if(down[i][j]==-1){

                    int tmp=dfs(i,j);

                    ans=max(ans,tmp);

                }

            }

        }

        printf("%d\n",ans);

    }

    return 0;

}

  

你可能感兴趣的:(poj)