PAT 1035 Password (20 分)————Python

1035 Password (20 分)
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.


Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.


Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.


Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题目大意
就是让你修改密码,其他的就没啥说的了。


Code

def func():
    n = int(input())
    count = n
    a = {
     '1':'@','0':'%','l':'L','O':'o'}
    result = []
    for x in range(n):
        line = input().split(' ')
        tag = False
        for i in a:
            if i in line[1]:
                tag = True
                line[1] = line[1].replace(i,a[i])
        if tag == True:
            result.append([line[0], line[1]])
            count -= 1
    if len(result) !=0:
        print(len(result))
        for x in result:
            print(x[0],x[1])
    elif count > 0 :
        if count == 1:
            print('There is 1 account and no account is modified')
        else:
            print('There are {} accounts and no account is modified'.format(count))
func()

注意:代码中的tag是防止重复输出的作用,十分重要。如果不加tag判断的话,碰到一个密码修改多次的情况它就会每修改一次输出一次,导致重复输出。


运行结果
PAT 1035 Password (20 分)————Python_第1张图片

你可能感兴趣的:(PAT,python)