poj2945

Find the Clones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5391 Accepted: 1998

Description

Doubleville, a small town in Texas, was attacked by the aliens. They have abducted some of the residents and taken them to the a spaceship orbiting around earth. After some (quite unpleasant) human experiments, the aliens cloned the victims, and released multiple copies of them back in Doubleville. So now it might happen that there are 6 identical person named Hugh F. Bumblebee: the original person and its 5 copies. The Federal Bureau of Unauthorized Cloning (FBUC) charged you with the task of determining how many copies were made from each person. To help you in your task, FBUC have collected a DNA sample from each person. All copies of the same person have the same DNA sequence, and different people have different sequences (we know that there are no identical twins in the town, this is not an issue).

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 20000 people, and the length 1 ≤ m ≤ 20 of the DNA sequences. The next n lines contain the DNA sequences: each line contains a sequence of m characters, where each character is either `A', `C', `G' or `T'. 

The input is terminated by a block with n = m = 0 .

Output

For each test case, you have to output n lines, each line containing a single integer. The first line contains the number of different people that were not copied. The second line contains the number of people that were copied only once (i.e., there are two identical copies for each such person.) The third line contains the number of people that are present in three identical copies, and so on: the i -th line contains the number of persons that are present in i identical copies. For example, if there are 11 samples, one of them is from John Smith, and all the others are from copies of Joe Foobar, then you have to print `1' in the first andthe tenth lines, and `0' in all the other lines.

Sample Input

9 6
AAAAAA
ACACAC
GTTTTG
ACACAC
GTTTTG
ACACAC
ACACAC
TCCCCC
TCCCCC
0 0

Sample Output

1
2
0
1
0
0
0
0
0

Hint

Huge input file, 'scanf' recommended to avoid TLE. 

Source


 
用STL的算法2维数组是不行的,需要封装到结构中。。。C++还是太弱了。
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct
{
    char dna[21];
}Node;
Node man[20000];
int rlt[20000];
int n,m;

bool cmp(Node man1, Node man2)
{
    if(strcmp(man1.dna,man2.dna)<=0)
        return false;
    else
        return true;
}
int main()
{
    int start,end;
    char temp[21];

    while(scanf("%d%d",&n,&m)!=EOF && (n+m))
    {
        memset(rlt,0,sizeof(rlt));
        memset(man,0,sizeof(man));
        for(int i=0; i<n; i++)
            scanf("%s",man[i].dna);

        sort(man, man+n,cmp);

        strcpy(temp,man[0].dna);
        start=0;
        end=0;
        for(int i=1; i<=n; i++)
        {
            if(!strcmp(temp,man[i].dna))
            {
                end=i;
            }
            else
            {
                rlt[end-start]++;
                start=i;
                end=i;
                strcpy(temp,man[i].dna);
            }
        }
        for(int i=0; i<n; i++)
            printf("%d\n",rlt[i]);
    }
    return 0;
}

你可能感兴趣的:(poj)