poj2363

Blocks

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5381 Accepted: 2555

Description

Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the blocks together into a rectangular solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?

Input

The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.

Output

Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.

Sample Input

5
9
10
26
27
100

Sample Output

30
34
82
54
130

Source


 
DFS枚举
#include <iostream>

using namespace std;

int min_v;
int blocks;
int a[2];

void DFS(int depth, int rem)
{
    if(depth>=2)
    {
        int sum=2*rem*a[1]+2*rem*a[0]+2*a[1]*a[0];
        if(sum<min_v)
            min_v=sum;
        return;
    }

    for(int i=rem; i>=1; i--)
    {
        if(rem%i==0)
        {
            a[depth]=i;
            DFS(depth+1,rem/i);
            a[depth]=0;
        }
    }
}

int main()
{
    int C;

    cin>>C;
    while(C--)
    {
        min_v=99999999;
        cin>>blocks;
        for(int i=0; i<2; i++)
            a[i]=0;
        DFS(0,blocks);
        cout<<min_v<<endl;
    }
    return 0;
}

你可能感兴趣的:(poj)