1056 Mice and Rice (25分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

#include "cstdio"
#include "iostream"
#include "string"
#include "algorithm"
#include "vector"
#include "cstring"
#include "set"
#include "map"
#include "math.h"
#include "stack"
#include "queue"
using namespace std;
const int MAX = 0x3fffffff;
const int maxn = 100010;
struct Mice{
    int weight;
    int order;
    int ranks;
    int id;
};
bool cmp(Mice a, Mice b){
    return a.order > b.order;
}
bool cmp1(Mice a, Mice b){
    return a.id < b.id;
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("sample.txt", "r", stdin);
    #endif
    int n, group;
    cin >> n >> group;
    vector v;
    queue q;
    v.resize(n);
    for(int i = 0; i < n; i++){
        scanf("%d", &v[i].weight);
        v[i].id = i;
        v[i].order = 1;
    }
    Mice m, maxMice;
    int temp;
    for(int i = 0; i < n; i++){
        scanf("%d", &temp);
        q.push(v[temp]);
    }
    int rankList = 0;
    while(!q.empty()){
        int cycle = q.size() / 3;
        rankList++;
        if(q.size() % 3 != 0){//本次比赛一共进行cycle次循环
            cycle++;
        }
        for(int k = 0; k < cycle; k++){
            maxMice.weight = -1;
            maxMice.order = rankList;
            for(int i = 0; !q.empty() && i < 3; i++){
                m = q.front();
                if(m.order != rankList){
                    break;
                }
                v[m.id].order = rankList;
                if(m.weight > maxMice.weight){
                    maxMice = m;
                    maxMice.order++;
                }
                q.pop();
            }
            if(!q.empty()){
               q.push(maxMice);
            }
        }
    }
    int miceNum = 1;
    int ranker = 1;
    v[maxMice.id].order++;
    sort(v.begin(), v.end(), cmp);
    v[0].ranks = 1;
    for(int i = 1; i < v.size(); i++){
        miceNum++;
        if(v[i].order == v[i - 1].order){
            v[i].ranks = v[i - 1].ranks;
        }else{
            v[i].ranks= miceNum;
        }
    }
    sort(v.begin(), v.end(), cmp1);
    printf("%d", v[0].ranks);
    for(int i = 1; i < v.size(); i++){
        printf(" %d", v[i].ranks);
    }
    return 0;

最后两个测试点没有通过,实时改正,希望有大佬可以留言更正,不胜感激。

你可能感兴趣的:(c++)