杭电1021

好吧这题我承认我刚开始没发现要找规律 老是超时;

 

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42613    Accepted Submission(s): 20339


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 


Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 


Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 


Sample Input
0 1 2 3 4 5
 


Sample Output
no no yes no no no
 
 
#include<stdio.h>

int main()

{

    int f[10000],i;

    int n;

    while(scanf("%d",&n)!=EOF)

    {

        if((n-2)%4==0)  

       printf("yes\n");  

   else  

       printf("no\n");//也是醉了原来是找规律 。 



    }

}

 

 

你可能感兴趣的:(杭电)