DFS解决POJ 1979

 

Description

 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

Input

 

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

 

Output

 

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

Sample Input

 

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

 

Sample Output

 

45

59

6

13

 

View Code
#include<iostream>

using namespace std;

int used[25][25];

char map[25][25];

int d[4][2] = {{-1,0}, {1,0}, {0,-1}, {0,1}};//4个方向的走法下,上,左, 右

int n, m;

int count;//记录走过的总数

void dfs(int i, int j)

{

    count++;

    used[i][j]=1;

    int ii;

    for(ii=0; ii<4; ii++)

    {

        if(i+d[ii][0]>=0 && i+d[ii][0]<n && j+d[ii][1]>=0 && j+d[ii][1]<m && map[i+d[ii][0]][j+d[ii][1]]=='.' && !used[i+d[ii][0]][j+d[ii][1]])

        {

            dfs(i+d[ii][0],j+d[ii][1]);

        }

    }

}

int main()

{

    int start_i, start_j, i, j;

    while(cin>>m>>n && (n+m))

    {

        memset(used, 0, sizeof(used));

        for(i=0; i<n; i++)

        {

            for(j=0; j<m; j++)

            {

                cin>>map[i][j];

                if(map[i][j]=='@')

                {

                    start_i = i;

                    start_j = j;

                }

            }

        }

        count = 0;

        dfs(start_i, start_j);

        cout<<count<<endl;

    }

    return 0;

}

 

 

你可能感兴趣的:(poj)