Fibonacci Again

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no

 

#include<stdio.h>

int a[1000001];

int main()

{



    a[0]=1;

    a[1]=2;

    long int q,w;

    for(w=2;w<1000000;w++)

    {

        a[w]=a[w-1]+a[w-2];

        if(a[w]%3==0)

            a[w]=0;

        else

            a[w]=a[w]%3;

    }

    while(scanf("%ld",&q)!=EOF)

    {

        if(a[q]%3==0)

            printf("yes\n");

        else

            printf("no\n");

    }

    return 0;

}

你可能感兴趣的:(fibonacci)