I Love You Too HDU 2816

Description

This is a  true story. A man showed his love to a girl,but the girl didn't replied clearly ,just gave him a Morse Code: 
****-/*----/----*/****-/****-/*----/---**/*----/****-/*----/-****/***--/****-/*----/----*/**---/-****/**---/**---/***--/--***/****-/   He was so anxious that he asked for help in the Internet and after one day a girl named "Pianyi angel" found the secret of this code. She translate this code as this five steps: 
1.First translate the morse code to a number string:  4194418141634192622374
2.Second she cut two number as one group  41 94 41 81 41 63 41 92 62 23 74,according to standard Mobile phone can get this alphabet: GZGTGOGXNCS
I Love You Too HDU 2816
3.Third she change this alphabet according to the keyboard:  QWERTYUIOPASDFGHJKLZXCVBNM = ABCDEFGHIJKLMNOPQRSTUVWXYZ
So ,we can get  OTOEOIOUYVL
4.Fourth, divide this alphabet to two parts:  OTOEOI and  OUYVL, compose again.we will get  OOTUOYEVOLI
5.Finally,reverse this alphabet the answer will appear :  I LOVE YOU TOO
I Love You Too HDU 2816
I guess you might worship Pianyi angel as me,so let's Orz her. 
Now,the task is translate the number strings. 
 

Input

A number string each line(length <= 1000). I ensure all input are legal.
 

Output

An upper alphabet string.
 

Sample Input

4194418141634192622374 41944181416341926223
 

Sample Output

ILOVEYOUTOO VOYEUOOTIO
 
 
 
 
 
#include<iostream>

#include<cstdio>

#include<cstring>

#include<algorithm>

#include<cmath>

#include<queue>

using namespace std;



int main()

{

    char ss[1314],s[1314];

    char* a[]={"ABC","DEF","GHI","JKL","MNO","PQRS","TUV","WXYZ"};

    char b[]="KXVMCNOPHQRSZYIJADLEGWBUFT";

    char d[]="QWERTYUIOPASDFGHJKLZXCVBNM";

    //for(int i=0;i<26;i++)

    //    cout<<b[d[i]-'A']<<" ";

    while(gets(ss))

    {

        int m=strlen(ss);

        int len=0;

        for(int i=0;i<m;i++)

            if(ss[i]!=' ')

                s[len++]=ss[i];

        char s0[520];

        int x=0;

        for(int i=0;i<len;i+=2)

        {

            s0[x++]=b[a[s[i]-'2'][s[i+1]-'1']-'A'];

            

        }

        char s1[520];

        int y=0;

        for(int i=0;i<x;i+=2)

        {

            s1[i]=s0[y++];    

        }

        for(int i=1;i<x;i+=2)

        {

            s1[i]=s0[y++];

        }

        for(int i=y-1;i>=0;i--)

        {

            putchar(s1[i]);

        }

        printf("\n");

    }

}

 

 

你可能感兴趣的:(love)