IPv6NAT-PT实验:IPv4和IPv6地址转换的配置和验证
【实验目的】
熟悉IPv6NAT-PT的概念。
掌握静态IPv6NAT-PT的配置
掌握动态IPv6NAT-PT的配置。
验证配置。
【实验拓扑】
设备参数如下表所示。
设备 |
接口 |
IP地址 |
子网掩码 |
默认网关 |
R1 |
S0/0 |
192.168.12.1 |
24 |
N/A |
R2 |
S0/0 |
192.168.12.2 |
24 |
N/A |
S0/1 |
2000:F106:F208:23::2 |
64 |
N/A |
|
R3 |
S0/0 |
2000:F106:F208:23::2 |
64 |
N/A |
【实验配置】
1.基础配置
(1)IP地址和路由配置
①路由器R1。
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface s0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0
②路由器R2。
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ipv6 unicast-routing
R2(config)#interface s0/0
R2(config-if)#ip add 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0/1
R2(config-if)#ipv6 address 2000:f106:f208:23::2/64
R2(config-if)#no shutdown
③路由器R3。
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#interface s0/0
R3(config-if)#ipv6 address 2000:f106:f208:23::3/64
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 route ::/0 s0/0
(2)IPv6静态IPv6NAT-PT的配置
地址转换表如下表所示
地址转换表
内部IP地址 |
转换IP地址 |
192.168.12.1 |
2000:F106:F208:1::1 |
2000:F106:F208:23::3 |
192.168.3.3 |
(3)静态NAT-PT配置
R2(config)#ipv6 nat prefix 2000:F106:F208:1::/96
//配置用于NAT-PT转换的地址池,前缀长度必须是96,后缀地址由IPv4地址转换成16进制得出
R2(config)#ipv6 nat v4v6 source 192.168.12.1 2000:F106:F208:1::1
//R3访问地址2000:F106:F208:1::1时,地址转换为192.168.12.1
R2(config)#ipv6 nat v6v4 source 2000:F106:F208:23::3 192.168.3.3
//R1访问地址192.168.3.3时,地址转换为2000:F106:F208:23::3
R2(config)#interface s0/0
R2(config-if)#ipv6 enable
//连接IPv4网络的接口需要启用IPv6协议
R2(config-if)#ipv6 nat
//在接口启用NAT-PT
R2(config-if)#interface s0/1
R2(config-if)#ipv6 nat
2.实验调试
R2#debug ipv6 nat
//先在R2上开启NAT-PT的调试,再到R1进行ping测试
IPv6 NAT-PT debugging is on
R2#
R1#ping 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/68 ms
R1#
R1#
R2#show ipv6 nat translations
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
--- --- ---
192.168.12.1 2000:F106:F208:1::1
//前面配置的静态转换
icmp 192.168.3.3 2000:F106:F208:23::3
192.168.12.1 2000:F106:F208:1::1
//ping产生的临时转换规则
--- 192.168.3.3 2000:F106:F208:23::3
--- ---
R2#
地址转换表如下表所示
地址转换表
内部IP地址 |
转换IP地址 |
192.168.12.1 |
2000:F106:F208:1::1 |
2000:F106:F208:23::3 |
192.168.3.1~192.168.3.20 |
R2(config)#ipv6 nat prefix 2000:F106:F208:1::/96
R2(config)#ipv6 nat v4v6 source 192.168.12.1 2000:F106:F208:1::1
//配置IPv4到IPv6的静态转换条目
R2(config)#ipv6 accesss-list v6v4
R2(config-ipv6-acl)#permit ipv6 2000:F106:F208:23::/64 any
//匹配需要IPv6到IPv4动态转换的地址
R2(config-ipv6-acl)#exit
R2(config)#ipv6 nat v6v4 pool v6v4_Pool 192.168.3.1 192.168.3.20 prefix-length 24
//匹配需要IPv6到IPv4动态转换的地址池,名字为“v6v4_Pool”
R2(config)#ipv6 nat v6v4 source list v6v4 pool v6v4_Pool
//配置动态NAT-PT转换,关联地址池和ACL,可使用附加参数“overload”进行过载配置
R2(config)#interface s0/0
R2(config-if)#ipv6 enable
R2(config-if)#ipv6 nat
R2(config-if)#interface s0/1
R2(config-if)#ipv6 nat
3.实验调试
R2#debug ipv6 nat
//先在R2上开启NAT-PT的调试,再到R1进行ping测试
IPv6 NAT-PT debugging is on
R3#ping 2000:F106:F208:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:F106:F208:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
R3#
R2#show ipv6 nat translations
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
--- --- ---
192.168.12.1 2000:F106:F208:1::1
--- 192.168.3.1 2000:F106:F208:23::3
//动态NAT-PT从地址池第一个地址池建立转换关系
192.168.12.1 2000:F106:F208:1::1
--- 192.168.3.1 2000:F106:F208:23::3
--- ---
R2#
4.实验脚本:
(1)基础配置脚本
①路由器R1。
conf t
interface s0/0
ip add 192.168.12.1 255.255.255.0
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 s0/0
②路由器R2。
conf t
ipv6 unicast-routing
interface s0/0
ip add 192.168.12.2 255.255.255.0
no shutdown
exit
interface s0/1
ipv6 address 2000:f106:f208:23::2/64
no shutdown
③路由器R3。
conf t
interface s0/0
pv6 address 2000:f106:f208:23::3/64
no shutdown
exit
ipv6 unicast-routing
ipv6 route ::/0 s0/0
(2)静态NAT-PT配置脚本
ipv6 nat prefix 2000:F106:F208:1::/96
ipv6 nat v4v6 source 192.168.12.1 2000:F106:F208:1::1
ipv6 nat v6v4 source 2000:F106:F208:23::3 192.168.3.3
interface s0/0
ipv6 enable
ipv6 nat
interface s0/1
ipv6 nat
(3)动态NAT-PT配置脚本
ipv6 nat prefix 2000:F106:F208:1::/96
ipv6 nat v4v6 source 192.168.12.1 2000:F106:F208:1::1
ipv6 accesss-list v6v4
permit ipv6 2000:F106:F208:23::/64 any
exit
ipv6 nat v6v4 pool v6v4_Pool 192.168.3.1 192.168.3.20 prefix-length 24
ipv6 nat v6v4 source list v6v4 pool v6v4_Pool
interface s0/0
ipv6 enable
ipv6 nat
interface s0/1
ipv6 nat
【实验详解】
【复习巩固】
当谈到这个实验时,有几个关键的知识点需要理解。以下是每个知识点的详细解释,并附带了相应的例子来说明。
1.IPv6NAT-PT的概念:
2.静态IPv6NAT-PT的配置:
3.动态IPv6NAT-PT的配置:
3.实验调试和验证:
通过理解这些知识点,并参考实验中的配置和调试步骤,可以深入了解IPv6NAT-PT的概念、静态和动态配置方法,并验证其在IPv4和IPv6之间进行地址转换的能力。