求组合数的值(函数) python

目录

题目描述

AC代码


题目描述

编制程序,输入m,n(M>=n>=0)后,计算下列表达式的值并输出:

m!

n! (m-n)!

要求将该表达式的计算写成函数combination(m,n),返回计算结果。 阶乘计算写成函数fact(n),返回n!。

不可以使用Python内置包的数学函数

输入

m n

输出

对应表达式的值

输入样例1 

2 1

输出样例1

2

AC代码

def fact(n):
    factorial = 1
    for i in range(1, n + 1):
        factorial *= i
    return factorial


def combination(m, n):
    return fact(m) / (fact(n) * fact(m - n))


m, n = map(int, input().split())
print(combination(m, n))

你可能感兴趣的:(Python,OJ,python)