CISCO网络设备基本配置

交换机

1.交换机的工作模式

Switch>enable(用户模式)

Switch#configure  terminal(特权模式)

Switch(config)#interface fastEthernet 0/1(全局配置模式)

Switch(config-if)#ip address 192.168.1.1 255.255.255.0(接口模式)

no shutdown(开启接口)

exit返回上一模式

end直接退到特权模式

2.常用命令

特权模式下

show running-config(查看配置信息)
show version(查看IOS版本信息)
show mac-address-table(查看MAC地址表)
show interface fastethernet 0/1(查看接口信息双工和速率)
write(保存交换机配置)
reload(恢复设备出厂默认值)

全局模式下

hostname default(修改主机名)
enable password 123456(配置enable明文口令)
enable secret 123456(配置enable加密口令)
no ip domain-lookup(禁用DNS查询)

接口模式下

ip address ip地址 子网掩码(配置静态ip)
duplex [full|half|auto](全双工、半双工、自动)
speed[10|100|1000|auto](通信速率)

vlan的配置

vlan 10(创建vlan)
name aaa(进入vlan后给vlan命名)
interface vlan 10(进入vlan10)
ip address 192.168.1.10 255.255.255.0
no shutdown
no vlan 10(删除vlan)
interface range f0/1 – 10
switchport access vlan  10(将1-10接口划入vlan10)

默认网关配置

ip default-gateway 192.168.1.1

虚拟端口配置(telnet)

line vty 0 4
password 123456
login

路由器

查看路由表

show ip route

路由接口ip配置

intface serial0/1

ip address 192.168.1.1 255.255.255.0

clock rate 64000(设置时钟)

no shutdown

默认路由

ip route 0.0.0.0 0.0.0.0 下一跳

静态路由配置

ip route 目标网络ID 子网掩码 下一跳ip或设备出口的接口

RIP配置

route rip
network 192.168.10.0(路由中的网段)
network 192.168.20.0
version 2
no auto-summary

ospf配置

route ospf 10(设置进程号)
network 192.168.10.0 0.0.0.255 area 0(area设置区域号)
network 192.168.20.0 0.0.0.255 area 0

nat配置

ip nat inside source static 192.168.1.1 172.16.1.1(静态ip转换)
int f0/0
ip nat inside
int f0/1
ip nat outside

出口段连接的设备做ip route就好了

DHCP配置

ip route pool aaa(定义地址池)

network 192.168.1.0 255.255.255.0(动态分配)

default-router 192.168.1.1(动态分配网关)

dns-server 8.8.8.8(动态分配dns服务器地址)

exit

ip dhcp excluded-address 192.168.1.100 192.168.1.110(排除的ip地址)
ip helper-address 192.168.1.250(DHCP中继地址---向服务器请求分配DHCP地址)

ACL配置(acl编号取值范围(100-199))

access-list 101 deny host 192.168.1.10(拒绝ip为192.168.1.10的主机访问路由出口的主机)
access-list 101 deny any(允许其他的流量访问)
进入接口后
ip access-group 101 in(将ACL应用与接口,生效ACL配置)

扩展ACL配置(配置完后记得用access-group生效配置)

access-list 101 permit tcp 192.168.10.0 0.0.0.255 host 192.168.20.5 eq www|80(允许192.168.1.10的网段走tcp协议访问192.168.20.5的主机的万维网服务)

补充acl编号取值范围(100-199)

access-list 101 permit any any(允许其他网段访问)

show access-list 101(查看ACL信息)

三层交换机配置

开启路由功能

ip routing

配置trunk并封装

switchport  trunk  encapsulation  dot1q 
switchport  mode  trunk
no  switchport (进入真实接口)

。。

。。。

。。。。

。。。。。

三次在我感觉就是多了路由功能的交换机,配置看上面的就好了

单臂路由实例

[图片上传失败...(image-e00753-1581937956576)]

SW1配置
Switch>enable
Switch#config terminal
Switch(config)#hostname SW1
SW1(config)#vlan2 
SW1(config-vlan)#exit
SW1(config)vlan 3
SW1(config-vlan)exit
SW1(config)#interface fastEthernet 1/1
SW1(config-if)#switchport mode access(配置接口为access口,科普除trunk模式外还有access、hybrid)
SW1(config-if)#switchport access vlan 2
SW1(config-if)#exit
SW1(config)#interface fastEthernet 2/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 3
SW1(config-if)#exit
SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan 2,3(配置turnk口允许vlan2 和vlan3通过,除了vlan2和vlan3,其他所有的vlan默认拒绝所有,这里实验可加可不加)
R1配置
Switch>enable
Swtich#config terminal
Switch(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet0/0.1
R1(config-subif)#encapsulation dot1Q 2 
R1(config-subif)#ip address 192.168.2.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fastEthernet 0/0.2
R1(config-subif)#encapsulation dot1Q 3
R1(config-subif)#ip address 192.168.3.1 255.255.255.0

关于trunk、access、hybrid的理解

具有access性质的端口只能属于一个vlan,且端口不打tag

具有trunk性质的端口可以属于多个vlan,且端口都是打tag的

具有hubrid性质的端口可以属于多个vlan,是否打开tag由用户而定

tag的理解就想貼了同样标签的东西他们是可以互相通信的,比如小米手机用MIUI系统,而苹果手机用IOS系统

你可能感兴趣的:(CISCO网络设备基本配置)