light_oj 1370 欧拉函数+二分

light_oj 1370 欧拉函数+二分

A - Bi-shoe and Phi-shoe
Time Limit:2000MS      Memory Limit:32768KB      64bit IO Format:%lld & %llu
Submit  Status

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

#include<iostream>

#include<cstdio>

#include<cstring>

#include<cstdlib>

#include<algorithm>

#include<vector>

#include<stack>

#include<queue>

#include<set>

#include<map>

#include<string>

#include<math.h>

#include<cctype>



using namespace std;



typedef long long ll;

const int maxn=2000100;

const int INF=(1<<29);

const double EPS=0.0000000001;

const double Pi=acos(-1.0);



int n;

int euler[maxn];



void Init()

{

    euler[1]=1;

    for(int i=2;i<maxn;i++) euler[i]=i;

    for(int i=2;i<maxn;i++){

        if(euler[i]==i){

            for(int j=i;j<maxn;j+=i) euler[j]=euler[j]/i*(i-1);

        }

    }

}



int main()

{

    int T;cin>>T;

    int tag=1;

    Init();

    for(int i=2;i<maxn;i++) euler[i]=max(euler[i],euler[i-1]);

    while(T--){

        cin>>n;

        ll ans=0;

        while(n--){

            int t;

            scanf("%d",&t);

            ans+=lower_bound(euler+2,euler+maxn,t)-euler;

        }

        printf("Case %d: %lld Xukha\n",tag++,ans);

    }

    return 0;

}
View Code

 

你可能感兴趣的:(函数)