目录
核心交换机与出口路由器的连接
网络出口的配置
策略路由的配置
1.教学楼的流量走电信出口,宿舍楼流量走联通出口(基于源)
2.访问带内心的服务器走电信出口,访问联通服务器走联通出口
案例图如下:
acsw的配置
vlan batch 10 20
int g0/0/1
port link-type access
port default valn 10
int g0/0/2
port link-type access
port default vlan 20
int g0/0/3
port link-type trunk
port trunk allow-pass vlan all
coresw的配置
核心交换机需要配置为网关以及DHCP服务器
//配置网关
vlan batch 10 20 30
int g0/0/3
port link-type trunk
port trunk allow-pass vlan all
quit
interface vlanif 10
ip address 192.168.10.254 24
interface vlanif 20
ip address 192.168.20.254 24
//配置DHCP
dhcp enable
ip pool vlan10 //地址池的名字是vlan10
network 192.168.10.0 mask 24
gateway-list 192.168.10.254
dns-list 8.8.8.8
lease day 3
//网关地址为192.168.10.254,可用的地址限制为192.168.10.1
excluded ip-address 192.168.10.2 192.168.10.253
interface vlanif 10
//如果配置了vlanif 10 20,则PC1分配ip地址就会找与此网段相同网段的地址池
dhcp select global
ip pool vlan20 //地址池的名字是vlan20
network 192.168.20.0 mask 24
gateway-list 192.168.20.254
dns-list 114.114.114.114
lease day 10
excluded ip-address 192.168.20.2 192.168.20.253
interface vlanif 20
dhcp select global
至此PC1 ping PC2 能通,通信过程如下
1.PC1判断目的IP是否在同一网段 (与自身所在网段进行与运算)
2.交给网关,网关根据路由表(display ip routing-table)做路由转发
coresw的配置
int g0/0/1
port link-type access
port default vlan 30
int vlanif 30
ip address 192.168.30 254 24
出口路由器的配置
interface g0/0/1
ip address 192.168.30.3 24
//此时终端不能ping通出口路由,需要配置回程路由
ip route-static 192.168.10.0 255.255.255.0 192.168.30.254
也可以配置动态路由
RIP
//出口交换机配置
rip
version 2
network 192.168.30.0
//核心交换机
rip
version 2
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
OSPF
//出口路由器
ospf 1
area 0
network 192.168.30.0 0.0.0.255
//核心交换机
ospf 1
area 0
network 192.168.10.0 0.0.0.255
network 192.168.20.0 0.0.0.255
network 192.168.30.0 0.0.0.255
可以通过以下命令查看ospf状态:fool表示成功建立
补充:BGP的established表示成功建立
display ospf peer brief
出口路由器的配置
interface g0/0/0
ip address 12.1.1.3 24
interface g0/0/2
ip address 23.1.1.3 24
电信服务器的配置
int g0/0/0
ip address 12.1.1.1 24
int g0/0/1
ip address 100.1.1.1 24
//配置测试地址
int lo0
ip address 1.1.1.1 24
联通服务器的配置
interface g0/0/1
ip address 100.1.1.2
interface g0/0/02
ip address 23.1.1.2 24
//配置测试地址
ip address 2.2.2.2 24
配置动态路由,能够彼此学习路由
//电信服务器
rip
version 2
network 100.0.0.0
network 12.0.0.0
network 1.0.0.0
//联通服务器
rip
version 2
network 100.0.0.0
network 23.0.0.0
network 2.0.0.0
电信服务器和联通服务器能互相ping通
在出口路由器配置出口NAT
acl 2000
rule 10 permit source 192.168.10.0 0.0.0.255
rule 20 permit source 192.168.20.0 0.0.0.255
quit
int g0/0/0
nat outbound 2000
int g0/0/2
nat outbound 2000
这时PC ping 不通电信服务器,需要在核心交换机和出口路由都配置默认路由
核心交换机
ip route-static 0.0.0.0 0 192.168.30.3
出口路由器(优先走电信)
ip route-static 0.0.0.0 0 12.1.1.1 preference 50
ip route-static 0.0.0.0 0 23.1.1.2 //默认路由是60
若电信端口状态不正常,则走联通:配置bfd
undo ip route-static 0.0.0.0 0 12.1.1.1
bfd
bfd dianxin bind peer-ip 12.1.1.1 source-ip 12.1.1.3 auto
电信服务器
由于模拟器不支持单边使用bfd,所以电信服务器也需要配置bfd
bfd
bfd dianxin bind peer-ip 12.1.1.3 source-ip 12.1.1.1 auto
可以通过以下命令查看bfd状态(up/down)
display bfd session all
在出口路由器跟踪
ip route-static 0.0.0.0 0 12.1.1.1 preference 50 track bfd-session dianxin
所有流量默认走电信,如果电信出现故障,bfd状态转换为down,流量切换到联通
display ip routing-table
走电信路由
无论访问联通还是电信,都是走联通路由
出口路由器的配置
acl 2010
rule 10 permit source 192.168.10.0 0.0.0.255
acl 2020
rule 10 permit source 192.168.20.0 0.0.0.255
//流分类
traffic classifier jiaoxue
if match acl 2010
quit
traffic classifier sushe
if match acl 2020
quit
//流行为
traffic behavior re-dianxin
redirect ip-nexthop 12.1.1.1
quit
traffic behavior re-liantong
redirect ip-nexthop 23.1.1.2
quit
//流策略
traffic policy p
classifier jiaoxue behavior re-dianxin
classifier sushe behavior re-liantong
interface g0/0/1
traffic-policy p inbound
quit
PC1无论tracert 1.1.1.1还是2.2.2.2,都是走电信
和上一个配置的区别只在ACL的配置
出口路由器的配置
acl 3010
rule 10 permit ip source any destination 1.1.1.0 0.0.0.255
//匹配任意源地址去往电信服务器1.1.1.1的流量
acl 3020
rule 10 permit ip source any destination 2.2.2.0 0.0.0.255
//匹配任意源地址去往电信服务器2.2.2.2的流量