http://acm.hdu.edu.cn/showproblem.php?pid=1072
Nightmare
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3220 Accepted Submission(s): 1636
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.
Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.
Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1
Sample Output
4
-1
13
还是一道广搜题,用优先队列或者队列都可以~~思路很简单,就是要判断到达终点前炸弹会不会爆炸~~~
中间迷糊了一下,把结束条件的时间放到btime判断后面了,wa了几次,很郁闷~~
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
typedef struct node
{
int v;
int step;
int btime;
}State;
int d[2][4] = {-1, 1, 0, 0, 0, 0, -1, 1};
int map[10][10], m, n, bx, by, ex, ey, nx, ny, x, y;
State begin;
queue<State> q;
void bfs(int x, int y)
{
begin.v = x * n + y;
begin.step = 0;
begin.btime = 6;
q.push(begin);
while(!q.empty())
{
State u = q.front();
q.pop();
x = u.v / n;
y = u.v % n;
if(u.btime == 1)
continue;
/*if(map[x][y] == 3)
{
printf("%d\n", u.step);
return;
}*/
//刚开始把结束条件写到这里了-_-||
for(int i = 0; i < 4; i++)
{
nx = x + d[0][i];
ny = y + d[1][i];
State v = u;
v.v = nx * n + ny;
if(nx >= 0&&ny >= 0&&nx < m&&ny < n&&map[nx][ny])
{
v.step++;
v.btime--;
if(map[nx][ny] == 3)
{
printf("%d\n", v.step);
return;
}
if(map[nx][ny] == 4)
{
v.btime = 6;
map[nx][ny] = 0;
}
q.push(v);
}
}
}
printf("-1\n");
}
int main()
{
int tcases;
cin >> tcases;
while(tcases--)
{
cin >> m >> n;
for(int i = 0; i < m; i++)
{
for(int j = 0; j < n; j++)
{
cin >> map[i][j];
if(map[i][j] == 2)
{
bx = i; by = j;
}
}
}
bfs(bx, by);
while(!q.empty())
q.pop();
}
return 0;
}