POJ 3468

A Simple Problem with Integers
 
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 54392   Accepted: 16353
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5

1 2 3 4 5 6 7 8 9 10

Q 4 4

Q 1 10

Q 2 4

C 3 6 3

Q 2 4

Sample Output

4

55

9

15

update:成段增减 query:区间求和
#include<cstdio>

#include<cstring>

#define lson l, m, rt<<1

#define rson m+1, r, rt<< 1|1

#define LL long long

#define maxn 111110

LL add[maxn<<2];

LL sum[maxn<<2];

void PushUp(int rt)

{

    sum[rt] = sum[rt<<1] + sum[rt<<1|1];

}

void PushDown(int rt,int m)

{

    if(add[rt])

    {

        add[rt<<1] += add[rt];

        add[rt<<1|1] += add[rt];

        sum[rt<<1] += add[rt]*(m-(m>>1));

        sum[rt<<1|1] += add[rt] * (m>>1);

        add[rt] = 0;

    }

}

void build(int l,int r,int rt)

{

    add[rt] =0;

    if(l == r)

    {

        scanf("%lld",&sum[rt]);

        return ;

    }

    int m=(l+r)>>1;

    build (lson);

    build(rson);

    PushUp(rt);

}

void update(int L,int R,int c,int l,int r,int rt)

{

    if(l >=L && r <=R)

    {

        add[rt] += c;

        sum[rt] += (LL)c*(r-l+1);

        return ;

    }

    PushDown(rt,r-l+1);

    int  m=(l+r)>>1;

    if(m>=L) update(L,R,c,lson);

    if(m<R) update(L,R,c,rson);

    PushUp(rt);

}

LL query (int L,int R,int l,int r,int rt)

{

    if(l>=L && r<=R)

    {

        return sum[rt];

    }

    PushDown(rt,r-l+1);

    int m =(l+r)>>1;

    LL ret =0;

    if(m>=L) ret += query(L,R,lson);

    if(m<R) ret += query(L,R,rson);

    return ret;

}

int main()

{

    int N,Q;

    while(~scanf("%d%d",&N,&Q))

    {

        memset(add,0,sizeof(add));

        memset(sum,0,sizeof(sum));

        build(1,N,1);

        char op;

        int  a,b;

        long long c;

        for(int i=0; i<Q; i++)

        {

            getchar();

            scanf("%c",&op);

            if(op=='Q')

            {

                scanf("%d %d",&a,&b);

                printf("%lld\n",query(a,b,1,N,1));

            }

            else if(op=='C')

            {

                scanf("%d %d %d",&a,&b,&c);

                update(a,b,c,1,N,1);

            }

        }

    }

    return 0;

}
View Code

 



你可能感兴趣的:(poj)