Python 编写一个函数cacluate

编写一个函数cacluate, 可以接收任意多个数, 返回的是一个元组.元组的第一个值为所有参数的平均值(均值保留一位小数), 第二个值是大于平均值的所有值

【输入形式】
【输出形式】
【样例输入】

Please input numbers,and press the Enter to end.(gap with )

1,2,3,4,5


【样例输出】

(3.0, [4, 5])

def caculate(n):
        a=sum(n)/len(n)
        for i in list(n):
            if i<=a:
                n.remove(i)
        return a,n
m=map(int,input('Please input numbers,and press the Enter to end.(gap with ,)\n').split(','))
n=list(m)
l=caculate(n)
print(l)

你可能感兴趣的:(python作业,python)