【编程-每日一练】

每日一练

题目

输入一个华氏温度,要求输出摄氏温度。公式为 c=5(F-32)/9,取位2小数。

例子

输入格式

一个华氏温度,浮点数

输出格式

摄氏温度,浮点两位小数

样例输入

-40

样例输出

c=-40.00

解析

  • 保留两位数
    • 1.’%.2f’%f
		f = 2.3456789
		print('%.2f'%f)
		print('%.3f'%f)
		print('%.4f'%f)

结果如下所示

		2.35
		2.346
		2.3457
  • 2.format函数
f = 2.3456789

print('{:.2f}'.format(f))
print('{:.3f}'.format(f))
print('{:.4f}'.format(f))

结果如下图所示

2.35
2.346
2.3457

代码

F = float(input())
c= 5*(int(F)-32)/9
print('c={:.2f}'.format(c))
print('c=%.2f'%c)

你可能感兴趣的:(编程,学习,python,学习)