HDU 2045 不容易系列之(3)—— LELE的RPG难题

不容易系列之(3)—— LELE的RPG难题

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23277 Accepted Submission(s): 9231


Problem Description
人称“AC女之杀手”的超级偶像LELE最近忽然玩起了深沉,这可急坏了众多“Cole”(LELE的粉丝,即"可乐"),经过多方打探,某资深Cole终于知道了原因,原来,LELE最近研究起了著名的RPG难题:

有排成一行的n个方格,用红(Red)、粉(Pink)、绿(Green)三色涂每个格子,每格涂一色,要求任何相邻的方格不能同色,且首尾两格也不同色.求全部的满足要求的涂法.

以上就是著名的RPG难题.

如果你是Cole,我想你一定会想尽办法帮助LELE解决这个问题的;如果不是,看在众多漂亮的痛不欲生的Cole女的面子上,你也不会袖手旁观吧?

 

 

Input
输入数据包含多个测试实例,每个测试实例占一行,由一个整数N组成,(0<n<=50)。
 

 

Output
对于每个测试实例,请输出全部的满足要求的涂法,每个实例的输出占一行。
 

 

Sample Input
1 2
 

 

Sample Output
3 6
import java.math.BigInteger;

import java.util.*;

public class Main {

    public static void main(String[] args) {

        Scanner sc=new Scanner(System.in);

        while(sc.hasNextInt()){

            int m=sc.nextInt();

            BigInteger a[]=new BigInteger[50];

            a[0]=BigInteger.valueOf(3);

            a[1]=BigInteger.valueOf(6);

            a[2]=BigInteger.valueOf(6);

            if(m==1) System.out.println("3");

            else if(m==2)System.out.println("6");

            else if(m==3) System.out.println("6");

            else{

                

                for(int i=3;i<m;i++){

                    a[i]=a[i-1].add(BigInteger.valueOf(2).multiply(a[i-2]));

                }

                System.out.println(a[m-1]);

            }

        }

    }

}

 

你可能感兴趣的:(HDU)