A - Max Sum Plus Plus 动态规划


A - Max Sum Plus Plus
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^


Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.


Output
Output the maximal summation described above in one line.


Sample Input

1 3 1 2 3 2 6 -1 4 -2 3 -2 3



Sample Output

6 8

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=1000005;
const int inf=999999999;
#define lson rt<<1,l,m
#define rson rt<<1|1,m+1,r
#define For(i,n) for(int i=1;i<=(n);i++)
template<class T>inline T read(T&x)
{
    char c;
    while((c=getchar())<=32);
    bool ok=false;
    if(c=='-')ok=true,c=getchar();
    for(x=0; c>32; c=getchar())
        x=x*10+c-'0';
    if(ok)x=-x;
    return x;
}
template<class T> inline void read_(T&x,T&y)
{
    read(x);
    read(y);
}
template<class T> inline void write(T x)
{
    if(x<0)putchar('-'),x=-x;
    if(x<10)putchar(x+'0');
    else write(x/10),putchar(x%10+'0');
}
template<class T>inline void writeln(T x)
{
    write(x);
    putchar('\n');
}
//  -------IO template------

int dp[maxn];
int maxx[maxn];
int a[maxn];
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        For(i,n)
        {
            read(a[i]);
            dp[i]=maxx[i]=0;
        }
        dp[0]=maxx[0]=0;
        int tmp=-inf;
        for(int i=1;i<=m;i++)
        {
            tmp=-inf;
            for(int j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1],maxx[j-1])+a[j];
                maxx[j-1]=tmp;
                tmp=max(tmp,dp[j]);
            }
        }
        writeln(tmp);
    }
    return 0;
}









你可能感兴趣的:(动态规划)