[HDOJ]_PID_2087_剪花布条

题目:

Problem Description

一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?



Input

输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的



花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。



Output

输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。



Sample Input

abcde a3

aaaaaa aa

#



Sample Output

0

3



Author

qianneng



Source

冬练三九之二



Recommend

lcy

代码:

#include <iostream>

#include <string>



using namespace std;



int main() {

    string S, T;



    while (cin >> S && S != "#") {

        cin >> T;



        unsigned int count = 0;

        for (string::size_type loc = 0;

            loc < S.size() - T.size() && (loc = S.find(T, loc)) != string::npos;

            loc += T.size()) {

                ++count;

        }



        cout << count << endl;

    }

    return 0;

}

 

你可能感兴趣的:(pid)