分支-13. 计算天数

本题要求编写程序计算某年某月某日是该年中的第几天。

输入格式:输入在一行中按照格式“yyyy/mm/dd”(即“年/月/日”)给出日期。注意:闰年的判别条件是该年年份能被4整除但不能被100整除、或者能被400整除。闰年的2月有29天。

输出格式:在一行输出日期是该年中的第几天。

输入样例1:2009/03/02
输出样例1:61
输入样例2:2000/03/02
输出样例2:62
import java.util.Scanner; 

public class Main 

{

    public static void main(String[] args)

    {

    Scanner input = new Scanner(System.in);

    String inputs = input.nextLine();

    String[] date = inputs.split("/");

    int length = date.length;

    int d[] = new int[length];

    for(int i = 0;i < length;i++)

       d[i] = Integer.parseInt(date[i]);

    int sum = 0;

    for(int j = 1;j < d[1];j++)

    {

        switch(j)

        {

            case 1:

            case 3:

            case 5:

            case 7:

            case 8:

            case 10:

            case 12:sum += 31;break;

            case 4:

            case 6:

            case 9:

            case 11:sum += 30;break;

            case 2:

                if(d[0] % 4 == 0 && d[0] % 100 != 0 || d[0] % 400 == 0)

                    sum += 29;

                else

                    sum += 28;

        }

    }

    System.out.print(sum + d[2]);

    }

}

 

你可能感兴趣的:(计算)