How far away[HDU2586]

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3423    Accepted Submission(s): 1274

Problem Description There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.  

Input First line is a single integer T(T<=10), indicating the number of test cases.   For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.   Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.  

Output For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.  

Sample Input

2

3 2

1 2 10

3 1 15

1 2

2 3

2 2

1 2 100

1 2

2 1  

Sample Output

10

25

100

100  

Source ECJTU 2009 Spring Contest  

Recommend lcy

#include<stdio.h>

#include<string.h>

#include<vector>

#define GS 40025

using namespace std;

vector<int> G[GS],E[GS];

int father[GS],Len[GS],Dep[GS];

int N;

void build(int R)

{

    for (int i=0;i<G[R].size();i++)

    {

        int v=G[R][i];

        if (v==father[R]) continue;

        father[v]=R;

        build(v);

    }

}

void dfs(int R)

{

    for (int i=0;i<G[R].size();i++)

    {

        int v=G[R][i];

        if (v==father[R]) continue;

        Dep[v]=Dep[R]+1;

        Len[v]=Len[R]+E[R][i];

        dfs(v);

    }

}

int LCA(int a,int b)

{

    if (a==b) return a;

    if (father[a]==b) return b;

    else if (father[b]==a) return a;

    if (Dep[a]<Dep[b]) return LCA(a,father[b]);

    else return LCA(father[a],b);

}

int main()

{

    int T,M;

    scanf("%d",&T);

    while (T--)

    {

        scanf("%d%d",&N,&M);

        for (int i=1;i<=N;i++) G[i].clear();

        for (int i=1;i<=N;i++) E[i].clear();

        for (int i=1;i<N;i++)

        {

            int x,y,c;

            scanf("%d%d%d",&x,&y,&c);

            G[x].push_back(y);

            G[y].push_back(x);

            E[x].push_back(c);

            E[y].push_back(c);

        }

        memset(father,-1,sizeof(father));

        build(1);

        Dep[1]=0;

        Len[1]=0;

        dfs(1);

        while (M--)

        {

            int x,y;

            scanf("%d%d",&x,&y);

            int F=LCA(x,y);

            printf("%d\n",Len[x]+Len[y]-2*Len[F]);

        }

    }

    return 0;

}
View Code

 

你可能感兴趣的:(HDU)