HDU-2710 Max Factor

看懂:          

                 Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3089    Accepted Submission(s): 985

Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 
Input
* Line 1: A single integer, N
* Lines 2..N+1: The serial numbers to be tested, one per line
 
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 
Sample Input
4
36
38
40
42
 
Sample Output
38
#include<stdio.h>
#include<string.h>
const int MAX=20005;
int s[MAX];
int main()
{
    int n,m,maxn,i,j,p;

    memset(s,0,sizeof(s));
    s[1]=1;
    for(i=2;i<MAX;i++)//筛选所有范围内的素数
    {
        if(s[i]==0)
        for(j=i;j<MAX;j+=i)
        {
            s[j]=i;
        }
    }
    while(~scanf("%d",&n))
    {
        maxn=-1;
        while(n--)
        {
            scanf("%d",&m);
            if(s[m]>maxn)
            {
                maxn=s[m];
                p=m;
            }
        }
    printf("%d\n",p);
    }
    return 0;
}
 

 

你可能感兴趣的:(HDU)