poj 1837 很不错的题

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5258 Accepted: 3120

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4     
-2 3 
3 4 5 8

Sample Output

2

Source

Romania OI 2002

题意:在平衡秤上,左右分别有n个固定点,给你m个重量的秤砣,要求你把这些秤砣全部用上并保持平衡,求这样的组合有多少?

思路:若用搜索耗时很大,20^20,肯定超时,
 

      这个题我做的时候是归类在0-1背包里,然后这题又不是常规的求最优解,所以可以联想到给出若干物品  求其能组合的类型有多少这类类型的题目,分析知它最大的值为20*15*25=7500,然后乘上20=15000。明显可以用数组装下。
      所以可以这样定义它的状态:dp[i][j]《i为(1,m),j为(-7500,7500)》即在用第i个秤砣的时候,在力矩为j的位置的组合数,然后其初始状态为d[0][7500]=1,即什么都不放时在平衡点的组合数为1;
其实数组书可以只用开到7500,因为超过3750就没必要继续保存即这种条件下已经不能回到平横状态了
#include <stdio.h>
#include <memory.h>
int f[21][8000];
int loc[21],w[21];
int main()
{
    int n,m,i,j,k;

    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1;i<=n;i++)
        scanf("%d",loc+i);
        for(i=1;i<=m;i++)
        scanf("%d",w+i);

        memset(f,0,sizeof(f));
        f[0][4000]=1;

        for(i=1;i<=m;i++)
          for(j=-4000;j<=4000;j++)
              if(f[i-1][j+4000])
              for(k=1;k<=n;k++)
              {
                  if(j+4000+loc[k]*w[i]<0||j+4000+loc[k]*w[i]>8000)
                    continue;
                   f[i][j+4000+loc[k]*w[i]]+=f[i-1][j+4000];
              }
        printf("%d\n",f[m][4000]);
    }
    return 0;
}

你可能感兴趣的:(poj)