UVA 264 - Count on Cantor

 

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

 

 

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

 

Input and Output

You are to write a program that will read a list of numbers in the range from 1 toand will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

 

The input list contains a single number per line and will be terminated by end-of-file.

 

Sample input

 

3
14
7

 

Sample output

 

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4

 

 

Solution1:

 

#define RUN
#ifdef RUN

#include<stdio.h>


// 1:第i条斜线有i个元素
// 2:前i条斜线共有k*(k+1)/2个数
// 3:若存在最小正整数k使得S(k)>=n,
// 则n是第k条斜线上的倒数第S(k)-n+1个数,
// 对应的值是S(k)-n+1 / k-S(k)+n
int main() {

#ifndef ONLINE_JUDGE
	freopen("264.in", "r", stdin);
	freopen("264.out", "w", stdout); 
#endif

  long n;
  while(scanf("%ld", &n) == 1) {
    long k = 1, s = 0;
    for(;;) {
      s += k;
	  
	  // 找到了最小正整数k
      if(s >= n) {
		if(k&1){
			printf("TERM %ld IS %ld/%ld\n", n, s-n+1, k-s+n);
		}
		else{
			printf("TERM %ld IS %ld/%ld\n", n, k-s+n, s-n+1);
		}
        break;
      }
      k++;
    }
  }
  return 0;
}

#endif



Solution2:

 

//#define RUN
#ifdef RUN

#include<stdio.h>
#include<math.h>
int main() {

#ifndef ONLINE_JUDGE
	freopen("264.in", "r", stdin);
	freopen("264.out", "w", stdout); 
#endif

  long n;
  while(scanf("%ld", &n) == 1) {
    long k = (long)floor((sqrt(8.0*n+1)-1)/2-1e-9)+1;
    long s = k*(k+1)/2;

	if(k&1){
		printf("TERM %ld IS %ld/%ld\n", n, s-n+1, k-s+n);
	}
	else{
		printf("TERM %ld IS %ld/%ld\n", n, k-s+n, s-n+1);
	}



  }
  return 0;
}

#endif



 



 

你可能感兴趣的:(count)