131.108.0.0被
137.99.0.0的一个子网分开,
131.108.0.0就是一个不连续网络。
非连续网络是由被其他主网络分割的同一主网络组成,如上图网络
Rip 是有类协议。当
rip在不同的网络边界上广播某个网络信息时,
rip 在主网络边界上汇总被广播的网络更新。当
R1通过
137.99.88.0向
R2发送包含
131.108.5.0的更新时,它把
131.108.5.0/24转换成
131.108.0.0/16。该过程称为自动汇总。
R1#
interface Loopback0
ip address 131.108.5.1 255.255.255.0
!
interface Ethernet0/0
ip address 137.99.88.1 255.255.255.0
router rip
network 131.108.0.0
network 137.99.0.0
R2#
interface Loopback0
ip address 131.108.2.2 255.255.255.0
interface Ethernet0/0
ip address 137.99.88.2 255.255.255.0
router rip
network 131.108.0.0
network 137.99.0.0
R1在向
R2发送更新前先进行以下几步:
1、
131.108.5.0/24是否与更新的接口所在的子网
137.99.88.0/24处于同一主网络?
2、不在同一主网络。
R1汇总
131.108.5.0并广播路由
131.108.0.0/16。
R1#debug ip rip 显示
R1发送的更新
RIP protocol debugging is on
01:25:49: RIP: received v1 update from 137.99.88.2 on Serial2/1
01:25:49: 131.108. 0.0 in 1 hops
R2在向
R1接收更新前先进行以下几步:
1、
接收到的主网络
131.108.0.0与接收更新的接口的子网
137.99.88.0/24所在的主网络是否相同“?
2、
不在同一主网络。在从接收更新的其它接口得到的路由表中是否存在该主网络的任一子网?
3、
存在,因此
R2忽略该更新。
R2#debug ip rip //显示
R2发送的更新
RIP protocol debugging is on
*Mar 1 00:56:21.343: RIP: sending v1 update to 255.255.255.255 via Ethernet0/0 (137.99.88.2)
*Mar 1 00:56:21.347: RIP: build update entries
*Mar 1 00:56:21.347: network 131.108.0.0 metric 1
*Mar 1 00:56:21.347: RIP: sending v1 update to 255.255.255.255 via Loopback0 (131.108.2.2)
*Mar 1 00:56:21.351: RIP: build update entries
*Mar 1 00:56:21.351: network 137.99.0.0 metric 1
//路由表显示
rip更新已被忽略
.
131.108.0.0上的任何子网和网络的唯一入口是与
Loopback0直接相连的接口。
R2#show ip route
137.99.0.0/24 is subnetted, 1 subnets
C 137.99.88.0 is directly connected, Ethernet0/0
131.108.0.0/24 is subnetted, 1 subnets
C 131.108.2.0 is directly connected, Loopback0
解决方法
:在指向指定子网的两个路由器上配置静态路由可以避免更新忽略
.
R1(config)#ip route 131.108.2.0 255.255.255.0 137.99.88.2
R2(config)#ip route 131.108.5.0 255.255.255.0 137.99.88.1
R1# SHOW IP ROUTE
137.99.0.0/24 is subnetted, 1 subnets
C 137.99.88.0 is directly connected, Ethernet0/0
131.108.0.0/24 is subnetted, 2 subnets
C 131.108.5.0 is directly connected, Loopback0
S 131.108.2.0 [1/0] via 137.99.88.2
R2#show ip route
137.99.0.0/24 is subnetted, 1 subnets
C 137.99.88.0 is directly connected, Ethernet0/0
131.108.0.0/24 is subnetted, 2 subnets
S 131.108.5.0 [1/0] via 137.99.88.1
C 131.108.2.0 is directly connected, Loopback0
R2#ping 131.108.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 131.108.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/35/44 ms