HDU2058

The sum problem
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6675    Accepted Submission(s): 2066


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.


Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.



Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.



Sample Input
20 10
50 30
0 0


Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]


Author
8600



#include <stdio.h>
#include <math.h>
int main()
{
	int n, m, len, a;
	while(~scanf("%d%d", &n,&m))
	{
		if(!n && !m)
			break;
		len = sqrt(double(m * 2)) + 1;
		//根据等差数列来算,数列长度
		// m = (a + a + len - 1) * len / 2
		// m = a * len + len(len - 1)/ 2
		// m - len * (len - 1) / 2 = a * len
		//a = m / len - (len - 1) / 2
		while(--len)
		{
			a = m / len - (len - 1) / 2;
			if((a + a + len - 1) * len / 2 == m)
			{
				printf("[%d,%d]\n", a, a+len - 1);
			}
		}
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(HDU)