谁动了我的网络系列 之 ospf 虚链路 &路由汇总








如图 :  r1  诸多 loo  口    2  和4 起虚链路    
   然后做路由汇总    

废话少说  上  show run嘞
r1#show run
Building configuration...

Current configuration : 1708 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback10
 ip address 10.10.10.10 255.255.255.0
!
interface Loopback20
 ip address 10.10.20.10 255.255.255.0
!
interface Loopback30
 ip address 10.10.30.10 255.255.255.0
!
interface Loopback40
 ip address 10.10.40.10 255.255.255.0
!
interface Loopback50
 ip address 10.10.50.10 255.255.255.0
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.10.10.0 0.0.0.255 area 0
 network 10.10.20.0 0.0.0.255 area 0
 network 10.10.30.0 0.0.0.255 area 0
 network 10.10.40.0 0.0.0.255 area 0
 network 10.10.50.0 0.0.0.255 area 0
 network 0.0.0.0 255.255.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r1# 


r2#show run
Building configuration...

Current configuration : 1367 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
 ip address 23.23.23.2 255.255.255.0
 serial restart-delay 0
!         
interface Serial0/1
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 area 0 range 10.10.0.0 255.255.0.0
 area 100 virtual-link 4.4.4.4
 network 2.2.2.0 0.0.0.255 area 0
 network 12.12.12.0 0.0.0.255 area 0
 network 23.23.23.0 0.0.0.255 area 100
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r2# 

r3#show run
Building configuration...

Current configuration : 978 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 ip address 23.23.23.3 255.255.255.0
 serial restart-delay 0
!         
interface Serial0/1
 ip address 34.34.34.3 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.0 0.0.0.255 area 100
 network 23.23.23.0 0.0.0.255 area 100
 network 34.34.34.0 0.0.0.255 area 100
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r3# 



r4#show run 
Building configuration...

Current configuration : 1045 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface Serial0/0
 ip address 34.34.34.4 255.255.255.0
 serial restart-delay 0
!         
interface Serial0/1
 ip address 45.45.45.4 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 area 0 range 10.10.0.0 255.255.0.0
 area 100 virtual-link 2.2.2.2
 network 4.4.4.0 0.0.0.255 area 100
 network 34.34.34.0 0.0.0.255 area 100
 network 45.45.45.0 0.0.0.255 area 200
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end       

r4#  


r5#show run
Building configuration...

Current configuration : 1026 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!         
!         
!         
!         
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface Serial0/0
 ip address 45.45.45.5 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.10.10.1 255.255.255.0
 no keepalive
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 100
 router-id 5.5.5.5
 log-adjacency-changes
 redistribute static subnets
 network 5.5.5.0 0.0.0.255 area 200
 network 45.45.45.0 0.0.0.255 area 200
!
ip http server
no ip http secure-server
ip classless
ip route 45.45.46.0 255.255.255.0 Serial0/1
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r5# 
r5#


本文出自 “荒原” 博客,谢绝转载!

你可能感兴趣的:(网络,休闲,ospf,路由汇总,虚链路)