example:cisco eigrp

 

CISCO CCNP EIGRP

 1,先配底层
R1:

en
config t
hostname R1
no ip domain-lookup
line console 0
no exec-timeout
logging syn
exit
int loopback 0
no shutdown
ip address 172.16.128.1 255.255.255.0
exit
int se 1/1
no shutdown
ip address 12.12.12.1 255.255.255.0
exit
int fa 0/0
no shutdown
ip address 192.168.10.101 255.255.255.0
end
config t
router eigrp 100
no auto-summary
network 172.16.128.1 0.0.0.0
network 12.12.12.0 255.255.255.0
network 192.168.10.0
end

R2:
en
config t
hostname R2
no ip domain-lookup
line console 0
no exec-timeout
logging syn
exit
int se 1/0
no shutdown
ip address 12.12.12.2 255.255.255.0
exit
int se 1/1
no shutdown
ip address 23.23.23.2 255.255.255.0
exit
router eigrp 100
no auto-summary
network 12.0.0.0
network 23.23.23.0 0.0.0.255
end

R3:
en
config t
hostname R3
no ip domain-lookup
line console 0
no exec-timeout
logging syn
exit
int fa 0/0
no shutdown
ip address 192.168.10.103 255.255.255.0
exit
int se 1/0
no shutdown
ip address 23.23.23.3 255.255.255.0
exit
int se 1/1
no shutdown
ip address 34.34.34.3 255.255.255.0
exit
int loopback 0
ip address 172.16.1.1 255.255.255.0
ip address 172.16.2.1 255.255.255.0 se
ip address 172.16.3.1 255.255.255.0 se
ip address 172.16.0.1 255.255.255.0 se
exit
router eigrp 100
no auto-summary
network 192.168.10.0
network 23.23.23.0 255.255.255.0
network 34.34.34.0 0.0.0.255
network 172.16.0.0
end

R4:
en
config t
hostname R4
no ip domain-lookup
line console 0
no exec-timeout
logging syn
exit
int se 1/0
no shutdown
ip address 34.34.34.4 255.255.255.0
exit
int se 1/1
no shutdown
ip address 202.119.248.66 255.255.255.0
exit
router eigrp 100
no auto-summary
network 34.34.34.4 0.0.0.0
end

R5:
en
config t
hostname R5
no ip domain-lookup
line console 0
no exec-timeout
logging syn
exit
int se 1/0
no shutdown
ip address 202.119.248.1 255.255.255.0
exit
int loopback 0
ip address 218.115.248.1 255.255.255.0
ip address 199.212.48.6 255.255.255.0 se
end

 2,R3的loopback0接口的网段汇总
eigrp的网段汇总是在每个出接口上面做汇总
R3:
config t
int fa 0/0
ip summary-address eigrp 100 172.16.0.0 255.255.252.0
exit
int se 1/0
ip summary-address eigrp 100 172.16.0.0 255.255.252.0
exit
int se 1/1
ip summary-address eigrp 100 172.16.0.0 255.255.252.0
end

 3,R1去往R3的loopback0达到不等价负载均衡,R3去往R1的loopback0达到不等价负载均衡
进入路由表的条件是先进入top表,然后是AD<n*FD
进入top表的条件是AD<FDmin
metric=(10000000/bw+delay/10)*256
R1:

config t
int fa 0/0
delay 10000
exit
router eigrp 100
variance 2
end

R3:
config t
int fa 0/0
delay 10000
exit
router eigrp 100
variance 2
end

4,R1和R3之间实施认证
eigrp这间做认证是先写好key,然后在接口下设用
R1:

config t
key chain wuhu
key 1
key-string cisco
exit
exit
int fa 0/0
ip authentication key-chain eigrp 100 wuhu
end

R3:
config t
key chain wuhu
key 1
key-string cisco
exit
exit
int fa 0/0
ip authentication key-chain eigrp 100 wuhu
end

5,R4是EIGRP自治系统的边界路由器,连接了ISP,R4宣告默认路由

写一条默认路由
宣告默认路由
R4:

config t
ip default-network 202.119.248.0
router eigrp 100
network 202.119.248.0
end


6,R4上实现PAT实现EIGRP自治系统能够访问公网IP
先在R5上面写一条静态路由
再在R4上面写一条静态路由
设置出入接口
R5:

config t
ip route 0.0.0.0 0.0.0.0 se 1/0
R4:
config t
ip route 0.0.0.0 0.0.0.0 se 1/1
int se 1/1
ip nat outside
exit
int se 1/0
ip nat inside
exit
access-list 1 permit any
ip nat inside source list 1 interface se 1/1 overload
 

7,打断DUAL查询的环路,配置合适的路由器为eigrp stub

R2:
config t
router eigrp 100
eigrp stub
exit


 

你可能感兴趣的:(Cisco,ccnp,EIGRP)