OSPF实验

拓扑如下:

Router1 E0/0 <----> Router2 E0/0
Router2 E0/1 <----> Router3 E0/1
Router3 E0/0 <----> Router4 E0/0
Router4 E0/1 <----> Router5 E0/1
实验目标:

掌握OSPF多区域的配置

掌握OSPF与其他路由协议的重分发

掌握OSPF末梢区域的配置

掌握OSPF虚链路的配置

掌握OSPF的认证

配置如下:

R1:

R1#show run
Building configuration...

Current configuration : 807 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
ip audit po max-events 100
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 1.1.1.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router rip
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end


R2:

R2#show run
Building configuration...

*Mar  1 01:39:43.135: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1043 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
ip audit po max-events 100
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 20.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 1.1.1.2 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 2.1.1.1 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router ospf 100
 router-id 20.1.1.1
 log-adjacency-changes
 no auto-cost
 redistribute rip metric 100 subnets
 network 2.1.1.0 0.0.0.255 area 0
 network 20.1.1.1 0.0.0.0 area 0
!
router rip
 redistribute ospf 100 metric 1
 network 1.0.0.0
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
 

R3:

R3#show ru
*Mar  1 01:40:17.587: %SYS-5-CONFIG_I: Configured from console by consolen
Building configuration...

Current configuration : 1068 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
ip audit po max-events 100
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 30.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 3.1.1.1 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/1
 ip address 2.1.1.2 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router ospf 100
 router-id 30.1.1.1
 log-adjacency-changes
 area 2 virtual-link 40.1.1.1 authentication-key david
 network 2.1.1.0 0.0.0.255 area 0
 network 3.1.1.0 0.0.0.255 area 2
 network 30.1.1.1 0.0.0.0 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end      
 

R4:

R4#show run
Building configuration...

Current configuration : 1104 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
ip audit po max-events 100
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 40.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 3.1.1.2 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/1
 ip address 4.1.1.1 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router ospf 100
 router-id 40.1.1.1
 log-adjacency-changes
 area 2 virtual-link 30.1.1.1 authentication-key david
 area 3 authentication
 area 3 stub
 network 3.1.1.0 0.0.0.255 area 2
 network 4.1.1.0 0.0.0.255 area 3
 network 40.1.1.1 0.0.0.0 area 2
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!        
!
end
 

R5:

R5#show run
Building configuration...

Current configuration : 978 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
ip audit po max-events 100
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 50.1.1.1 255.255.255.255
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/1
 ip address 4.1.1.2 255.255.255.0
 ip ospf authentication-key cisco
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router ospf 100
 router-id 50.1.1.1
 log-adjacency-changes
 area 3 authentication
 area 3 stub
 network 4.1.1.0 0.0.0.255 area 3
 network 50.1.1.1 0.0.0.0 area 3
 default-information originate always
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end      
 

Finished

本文出自 “境由心生 天道酬勤” 博客,谢绝转载!

你可能感兴趣的:(配置,职场,休闲,实验,ospf)